Installing OpenVPN on my OMV 5.5 with Docker/Portainer, DuckDNS and my TP-Link Wireless Router Archer C8 [Troubleshooting]

  • Hello world,

    first of all I need to admit that I really like this project of TDL and Co. I recently came across. Thanks for your passion to create something new and special. Btw I'm also a dad who likes to some extent techno in many genre- and technical "geek" ways and I'd describe myself as a beginner in linux, though I'm not an absolute one.

    But now to my troubleshooting I hope some can relate and also benefit from as I guess.

    As outlined I did this in the following sequence:


    First set DHCP Adress Reservation in my TP-Link Archer C8 Router according to manual. Set static IP for my OMV, which works. Then Port Forwarded Sercice-Port and Internal Port 1194 (as prompted in the openvpn server scripts) to my OMV static ip with TCP/UDP supported protocol, enabled and rebooted. So far, so good.

    I guess that's working all fine!


    I did everything according to this YT tut to install my DuckDNS Server on my OMV via Portainer/Docker:

    DuckDNS on OMV via Docker/Portainer

    Works like in the video, I also checked whether my ISP IP is updated and properly assigned to the subdomain and my logs of my DuckDNS container confirm smooting running, e.g. report updating of ISP IP if it took place once in a while.

    I guess that's working all fine!


    I did everything according to this YT tut to install my OPENVPN Server on my OMV via Docker:

    OPENVPN on OMV via Docker

    The installation is according to scripts and an openvpn image made for docker which is documented here and the volume needs to be installed in command line and cannot be conducted via portainer even though once you start the openvpn server it will correctly show up in portainer. Apparently, it works according to the tutorial all fine.

    But then when I try connecting via OpenVPN Connect App on my android phone, it can't connect and I can also see in my log live files in openvpn in portainer that no connection dialog begins, nothing happens according to the logs - no hand shake..nothing. But OpenVPN and DuckDNS Server is up running referring to portainer overview and the tuts I did in line before.

    ANY ADVICE? I want to make this work!!!

    Please don't come along with wireguard or any other prog in the first place except of very good reasons as I want to make this work first. I'm not about to give up but I feel a bit headless actually. Any clue of someone who is more familiar with setting up openvpn will be highly appreciated?

    All the best and here we go,

    OW ;)

  • In your router you say you forwarded port 1194. But did you also enable VPN Passthru in the “Advanced→Security→Basic Security” section?

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • If I try netcat to check my port forwarding by this guide:…t-forwarding-with-netcat/

    It says my port is filtered? But why, are these web services reliable?:

    I don't have a firewall on my omv machine running and if I temporarily disable my SPI firewall on my router it continues prompting no port forwarding...

    Is there any chance to further check it? I still have the feeling that my router is blocking it as I found some bad reviews of users struggeling with the same issue...

    I also updated the latest firmware of my router Archer C8 V2 from the mid of 2016, but still no luck...

    What else can you recommend? How can I pinpoint that the lacking ability of port forwarding of my router is the problem?

  • Sorry, I have no other ideas other than to say if the port is not open it will not work.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • You were right, I could adapt my port forwarding in my modem-router which didn't work well. Solution was to set it to factory settings and make it over again. That's it, now everything runs perfectly.

    I may make up another openvpn container with TCP@443 now where it's done.

    But thanks for your patience!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!