NextCloud Internal Server Error

  • Hi all,


    Something happened to my nextcloud seemingly over night. Whenever I go to my domain or locally I get an internal server error. I have tried digging through the logs, but I don't see any errors pertaining to it. Maybe I'm not looking at the right logs? Also my bookstack app is giving the same 500 error. Is it possibly something with my db? I haven't touched the db any time recently.


    If there are any logs you guys think might help, please let me know. I really don't want to have to rebuild nextcloud again.


    Thanks in advance.

  • I am running it in docker and using portainer. Here's the log from portainer.

    Doesn't look like there is anything useful in there.

  • Nothing there either.


  • I am going to just delete everything and start over, however, the file/folders in the /data directory are marked as read-only and I can't seem to get around that. I am running as root so permissions shouldn't be the issue. Any ideas on how to delete that?

  • They are located on mergerfs array under /data/nextcloud/


    Code
    drwxrwx--- 7 1000 1000 4096 Jun 5 12:51 nextcloud
    drwxr-s--- 5 root users 4096 Jun 5 12:46 nextcloud-backup
    drwxr-s--- 7 root users 4096 Jun 5 12:55 nextcloud-new

    There is the output of ls -l

  • Are you running the docker as root?

    You should not. And if you run the docker as another user, permissions are messed up and you might be able to fix permissions instead of reinstalling.


    On my installation the files are owned by the user that is running the docker. Group is "users".


    There might be issues to use docker on mergerfs. Not sure as I am not using mergerfs, but might be worth searching the forum.


    You should be able to delete the directories when you ssh in the server as root.

  • I run the docker as a user named docker1 which has been created in the GUI of OMV.


    The directories are owned by docker1:users.

    UID is 1000

    GID is 100 (as all users created in the GUI of OMV on a default installation)


    drwxr-sr-x 9 docker1 users 4096 May 15 21:11 nextcloud

  • The directories are owned by docker1:users.

    UID is 1000

    Just to clarify for rocketcoder the first user you create will have the UID is 1000. If you already have a user (or users) created and you create a new user to own dockers then that user will have a UID of 1001 (or higher, depending on how many users you already have). You may already know this. Just ICYMI.

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Hardware: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - NanoPi M4 (v.1), backup - Odroid XU4, Pi-Hole (DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user trying to convert to Linux on a HP dx2400, Debian 10 XFCE.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!