nzbget Docker fails connecting to any news server unless use IP addr: Could not resolve hostname

  • Hi - Hope I picked the right sub-forum for this. Just did a clean install of OMV5 and installed Docker for nzbget using pretty much the same parameters used for the same container in OMV4. Only some paths changed.

    I have 3 news servers configured in nzbget and every one of them fails if I use their regular domain names, but succeed if I use their corresponding IP address. This leads me to think it's a DNS issue. But I think DNS is configured properly. I have tried the Cloudfare DNS ( and google ( Makes no difference.

    root@omv:~# host is an alias for is an alias for has address has address

    I've put in a ticket to Usenetserver but I'm not expecting a lot of help. It's not really their problem, just verifying configuration with them.

    Any ideas?


    Mark M.

    PS: I did find one fairly recent posting about DNS problems but unfortunately I can't read German.

  • Get a shell inside the container and examine the /etc/resolv.conf file.

    docker exec -it nzbget /bin/bash
    cat /etc/resolv.conf

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • That's what it is supposed to look like. Not sure why it does't work.

    Use a translator for that German page.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Thanks for the tip re translator, I should have thought of that! Duh! I checked out Update does not work - DNS problem and at the very bottom found this:

    I answer to myself:

    after reading the test thread again, I noticed a configuration change that I had to make earlier in a different context because a similar problem had occurred. The bug was then under OMV 2.0.x and has apparently persisted until today.

    You have to do the following:

    echo "nameserver" >> /etc/resolvconf/resolv.conf.d/tail

    You can also enter other servers instead of the Google DNS server; I once tried the DNS servers from Open-DNS, they also work the same way. You can also edit the file /etc/resolvconf/resolv.conf.d/tail with WinSCP ...

    and then restart the server.

    root@omv:/etc/resolvconf# echo "nameserver" >> /etc/resolvconf/resolv.conf.d/tail
    -bash: /etc/resolvconf/resolv.conf.d/tail: No such file or directory
    root@omv:/etc/resolvconf# echo "nameserver" >> /etc/resolvconf/resolv.conf.d
    root@omv:~# cat /etc/resolvconf/resolv.conf.d

    I rebooted and it works!! If you could explain what the heck is happening here I'd really appreciate it!

    Also if you could please explain how the DNS setting in my router works with or against the OMV DNS setting. I haven't changed the router setting since I can't remember when.

    Thanks so much for your help! I don't know what I'd do without this forum.

  • There are bugs in the resolver implementation. Your router obtains DNS servers from your ISP, so using your router IP address as a DNS server allows it to act as a caching resolver. It could be slightly faster at performing lookups compared to your applications polling a DNS server out on the internet, but in my experience the improvement isn't noticable.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Update 6/9/20 (final update): Tried re-installing OMV5 on my backup server and none of these problems appeared. So that's a clue. Did another fresh install of OMV5 on my production server and boom! all my difficulties vanished. Can't explain it. Just updating this note in case someone runs into similar problems. Wish I could give a more definitive answer as to what was fixed by starting over.

    Update 6/7/20: Turns out the attempt to alter contents of /etc/resolvconf was wrong-headed. OMV5 uses systemd-resolvd not resolvconf. There were therefore no contents in /etc/resolvconf which is why my initial

    echo "nameserver" >> /etc/resolvconf/resolv.conf.d/tail

    failed and my subsequent clueless

    echo "nameserver" >> /etc/resolvconf/resolv.conf.d

    apparently worked but actually accomplished nothing. Can't explain why these steps seemed to fix domain resolution (briefly). Hallucinations?

    Tried the fix here: SOLVED Upgrade from OMV 4 to OMV5

    sudo systemctl disable systemd-resolved.service
    systemctl stop systemd-resolved.service
    sudo rm /etc/resolv.conf
    sudo vi /etc/resolv.conf
    systemctl start systemd-resolved.service
    sudo systemctl enable systemd-resolved.service

    .. using both and; still no joy.



    Sadly, failing again with exact same DNS issue. Can't explain how it could revert; perhaps I rebooted? Not that that explains anything.

    Well, I for one am putting this on the back burner. I have another machine running OMV4 that has none of these issues and will use it for this sort of network access (NzbGet, etc.) until I feel ready to start pulling hair out again.

    I'm just leaving this dispiriting note so no one is disappointed that the fix shown here doesn't last. For now.

  • markmarz

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!