SMB shares appear empty

  • Hi all,


    some days ago I‘ve installed OMV for the first time to have a powerful solution to manage my NAS. I‘ve installed OMV 5.5.2-1 on a Banana Pi with Armbian buster (Linux 5.4.43-sunxi). Everything is up-to-date. The Pi was freshly set-up for OMV.


    I‘ve connected 2 external hard drives via USB to the Pi. They are found and the file systems mounted, referenced and online. The file systems are NTFS and exfat. Both already did have files on them which I now want to share in a network with linux and widons laptops. Everybody should have full read and write access.


    My problem is that the SMB shares can be seen, but all shares appear empty. This is the case when viewing them from a windows 10 laptop as well as from my Ubuntu laptop.


    In OMV I've just a user and a group called „pi“. The shared folders (3 on one drive, and 1 on the second) are have read/write permissions for user „pi“. The relative path is “/“ as I want to see the whole partitions. For the SMB options, I‘ve selected the options „guest allowed“, „read only = no“ and „browsable = yes“. Sendfile and asynchronous I/O support are enabled.


    Log level is set to debug, but all log files are 0 bytes. So unfortunately no detailed error information is available.


    Does anyone have an idea? Everything looks good. The Samba config files also seem ok. FTP works without problems.


    Thanks for your help!


    Best regards

    Bastian

  • The issue is still not solved but I have found out some details:

    - FTP only works only on 1 exfat share (TOSHIBA). The other 3 are also acccessible but empty

    - When connecting via SSH directly on the server as root or pi I can see all files on the shares

    - TOSHIBA has the same file / folder permissions on the server than i.e. Elements1, both belong to root:root. Acc. to this privileges-and-permissions-explained-under-omv OMV usually asks for root:users. Yet, even as root I'm not allowed to change it.




  • Due to a couple of reasons I have exchanged my BananaPi with a RasPi4 8GB with a new SD card. Hoping that OMV now finally works I installed it with the same HDDs. Yet, the result is exactly the same. I can't see any of the data on the drives with SMB.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!