DNS not resolving

  • 2 of my OpenMediaVault servers, recently installed, fully updated, cannot resolve DNS queries (Can't ping google.com or Twitter.com).

    Here's what I've tried:

    resolvectl status  : showed that the global DNS server is 192.168.99.1 (wrong address):


    And that the Link DNS was 192.168.200.1 (my routers address):



    Trying to ping google fails:


    Can ping IP addresses:


    Tried changing the DNS server from omv-firstaid (static or DHCP IP: neither did work) and from omv web gui: Still cannot resolve DNS. With omv-firstaid I did set the DNS to : 208.67.222.222 (openDns)

    So I went and did edit :

    sudo nano /etc/resolv.conf

    And inserted the correct DNS server there.

    Before:


    After:




    Restart systemd-resolved:

    systemctl restart systemd-resolved

    Now if we go check: resolvectl status

    Global DNS is OK:


    Link DNS is still pointing to the DNS server that was set using omv-firstaid (208.67.222.222 openDns) (but still not used, since it's the "global" one that is used and not the "link" one):


    Can now ping google:


    In OMV GUI I can see the DNS I had set using omv-first aid (no more screen shots allowed here it seems :-) ) : 208.67.222.222


    So, changing the DNS via omv-firstaid or OMV web GUI does change the link DNS but the link DNS isn't used. It's the Global DNS that is used.


    Then I did :

    systemctl disable systemd-resolved


    systemctl stop systemd-resolved




    I Can still ping google.com after disabling systemd-resolved and rebooting OMV.


    I'm a bit puzzled. Why can't we just change the DNS from the Web GUI? Do we need system-resolved? If we disable it, will it be re-enabled by a future update?


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!