DNS controller?

  • Yes it's started:



    But DNS queries uses the DNS server specified in : /etc/resolv.conf (which is 8.8.8.8 in my case) instead of the server I had configured with OMV web GUI (64.6.64.6)/etc/resolv.conf :




    I'm not sure but it seems that there's no symlink for /etc/resolv.conf. Do you know how to check this exactly? I've tried this and it doesn't output the file we're looking for:

  • It seems it's not a symlink:


    root@openmediavault:/etc# readlink -f resolv.conf

    /etc/resolv.conf

    root@openmediavault:/etc#


    And it seems that /run/systemd/resolved/resolv.conf doesn't exist... :

    root@openmediavault:/# cd /run/systemd/resolved/

    -bash: cd: /run/systemd/resolved/: No such file or directory

    root@openmediavault:/#


    Do you have an idea of what's going on?

  • I had a typo in my /run path. I corrected the post but it should be: /run/systemd/resolve/resolv.conf


    What is the output of (cut&paste works): ls -al /run/systemd/resolve/resolv.conf


    If it is there, I would:


    sudo rm /etc/resolv.conf && sudo ln -s /run/systemd/resolve/resolv.conf /etc/

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yes it exists:

    root@openmediavault:~# ls -al /run/systemd/resolve/resolv.conf

    -rw-r--r-- 1 systemd-resolve systemd-resolve 637 Jun 18 12:59 /run/systemd/resolve/resolv.conf


    Content of /run/systemd/resolve/resolv.conf:

    nameserver 8.8.8.8

    nameserver 1.1.1.1

    nameserver 64.6.64.6

    search local


    Deleted /etc/resolv.conf and re-created it as a symlink:

    root@openmediavault:/etc#sudo rm /etc/resolv.conf && sudo ln -s /run/systemd/resolve/resolv.conf /etc/


    Now we can see that resolv.conf is a symlink within the /etc/ folder:

    root@openmediavault:/etc# ls -la /etc/ | grep "\->"

    lrwxrwxrwx 1 root root 35 Jun 16 19:51 localtime -> /usr/share/zoneinfo/America/Moncton

    lrwxrwxrwx 1 root root 19 Jun 16 17:43 mtab -> ../proc/self/mounts

    lrwxrwxrwx 1 root root 21 May 2 16:39 os-release -> ../usr/lib/os-release

    lrwxrwxrwx 1 root root 32 Jun 18 13:14 resolv.conf -> /run/systemd/resolve/resolv.conf

    lrwxrwxrwx 1 root root 13 Jun 16 17:27 rmt -> /usr/sbin/rmt


    Checked content: It was empty...

    sudo nano /etc/resolv.conf


    Restarted systemd-resolved:

    systemctl restart systemd-resolved


    Checked content:

    sudo nano /etc/resolv.conf

    Now the content is:

    nameserver 64.6.64.6


    The name server I had set using omv-firstaid!!! :)


    Did reboot OMV to make sure everything stays as it is.


    Checked which DSN server was used using dig:

    root@openmediavault:~# dig twitter.com

    ; <<>> DiG 9.11.5-P4-5.1+deb10u1-Debian <<>> twitter.com

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6226

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:

    ; EDNS: version: 0, flags:; udp: 512

    ;; QUESTION SECTION:

    ;twitter.com. IN A

    ;; ANSWER SECTION:

    twitter.com. 391 IN A 104.244.42.193

    twitter.com. 391 IN A 104.244.42.129

    ;; Query time: 60 msec

    ;; SERVER: 64.6.64.6#53(64.6.64.6)

    ;; WHEN: Thu Jun 18 13:43:59 UTC 2020

    ;; MSG SIZE rcvd: 72


    It's 64.6.64.6 . So it stayed the same.


    Let's do another check:


    root@openmediavault:~# resolvectl status


    Global

    LLMNR setting: yes

    MulticastDNS setting: yes

    DNSOverTLS setting: no

    DNSSEC setting: allow-downgrade

    DNSSEC supported: yes

    DNSSEC NTA: 10.in-addr.arpa

    16.172.in-addr.arpa

    168.192.in-addr.arpa

    .

    .

    .

    Link 2 (ens33)

    Current Scopes: DNS LLMNR/IPv4

    DefaultRoute setting: yes

    LLMNR setting: yes

    MulticastDNS setting: no

    DNSOverTLS setting: no

    DNSSEC setting: allow-downgrade

    DNSSEC supported: yes

    Current DNS Server: 64.6.64.6

    DNS Servers: 64.6.64.6


    Now it seems that the Global DNS isn't used. It's the Link 2 DNS that is used.


    Cool!^^


    Thanks a lot ryecoaaron!! (I did send you a PM would you please check it?)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!