Login Loop - Please help

  • Hi,


    After a reboot, I can't seem to login my OMV anymore.


    I know I'm using the correct password, however once the correct password is entered, the screen flashes and I wind up at the login menu again.


    I've logged in via root and checked that the root disk is not full.

    I've used the omv-firstaide to clear the webui cache.

    I've tried to manually clear the /var/lib/php/sessions.

    I just did an update last week so I should be using the latest version.


    Any other ideas I can try here?


    Thanks!

  • Having the same issue here, though I'm also getting the following error on the screen:

    Code
    Error #0:
    OMV\Exception: Failed to read file '/var/cache/openmediavault/cache.omv\controlpanel\login_js.json' (size=0). in /usr/share/php/openmediavault/json/file.inc:207
    Stack trace:
    #0 /usr/share/php/openmediavault/json/file.inc(223): OMV\Json\File->getContents()
    #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(198): OMV\Json\File->read()
    #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    #3 {main}
  • ok digging further..


    # tail -f !$

    tail -f /var/log/nginx/openmediavault-webgui_error.log

    2020/06/24 15:43:17 [error] 15870#15870: *9 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php/sessions/sess_6j6o343lk23kgeqm4, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 43" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "HEAD / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm-openmediavault-webgui.sock:", host: "127.0.0.1"


    So, looks like a permissions error accessing the sessions.


    # chmod 777 /var/lib/php/sessions


    Now it's working.


    Hope this helps someone else.

  • I'm having this issue now, can log into root via SSH and my admin password is correct as if I put in a wrong password it says it's incorrect. But putting the correct credentials in causes a login loop.


    I've tried all the commands above, and it's still not allowing me to login to the web interface.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!