cifs mount error(5): Input/output error

  • Hi!

    I have configured a server with Samba shares: I think every thing is correct but I cannot login into shares.

    The search on the internet and on this forum has brought no solution.

    Launching the command

    smbclient -L zeraqqu.local

    and after password (checked 100 times) I get

    Sharename Type Comment
    --------- ---- -------
    Architettura Disk Progetti in corso

    But trying to mount I receive:

    mount -t cifs -o username=crickyx // /home/crickyx//Architettura/
    Password for crickyx@// ********
    mount.cifs kernel mount options: ip=,unc=\\\Architettura,user=crickyx,pass=********
    mount error(5): Input/output error
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    root@Bisonx:~# echo $?

    Exit code of mount command is 32, mount failure but I can't figure out what error(5) is.

    Here I found that it was something related to domain name. I have checked what could be the problem:


    and for me is fine.s

    The user trebek says


    I solved this problem by checking my cifspw file, and making sure the domain name was correct.

    but I can't find this file on my system...

    Is there someone who can point me in the right direction?

    Thank you,


  • subzero79

    Approved the thread.
  • Failing to solve the problem, I re-installed everything all over again.

    This time, the first thing I tried to configure was smb: well, it gave me the same problem.

    The only thing I was deviating from the standard procedure is the manual ext4 formatting.

    Why was I doing it? Because for some reason the formatting via web interface was very slow (hours for a 4Tb drive).

    So I was resetting disks, creating and configuring Luks via UI but creating the filesystem by hand with mkfs.ext4.

    The partition is correctly read in the "File system" menu but I couldn't configure Samba.

    Creating the partition with the web interface works instead.

    I point out that users, permissions, shares, are exactly the same, also checked in the config.xml file.

    There is definitely some part that I didn't catch but I didn't understand which one.

    Thank you,


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!