Failed update can’t access gui or firstaid

  • Tried to run an update thismorning. It failed. Now I have no gui as it reports can’t connect to server. OMG-firstaid reports -bash: OMG-firstaid; command not found. Please help. I really don’t want to have to re-install

  • apt-get update produces;


    apt-get update

    Get:1 file:/var/cache/openmediavault/archives InRelease

    Ign:1 file:/var/cache/openmediavault/archives InRelease

    Get:2 file:/var/cache/openmediavault/archives Release

    Ign:2 file:/var/cache/openmediavault/archives Release

    Get:3 file:/var/cache/openmediavault/archives Packages

    Ign:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Get:3 file:/var/cache/openmediavault/archives Packages

    Ign:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Get:3 file:/var/cache/openmediavault/archives Packages

    Ign:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Get:3 file:/var/cache/openmediavault/archives Packages

    Ign:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Get:3 file:/var/cache/openmediavault/archives Packages

    Ign:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Get:3 file:/var/cache/openmediavault/archives Packages

    Ign:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Get:3 file:/var/cache/openmediavault/archives Packages

    Get:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Ign:4 file:/var/cache/openmediavault/archives Translation-en_GB

    Get:5 file:/var/cache/openmediavault/archives Translation-en

    Ign:5 file:/var/cache/openmediavault/archives Translation-en

    Hit:6 http://packages.openmediavault.org/public usul InRelease

    Hit:7 http://security.debian.org/debian-security buster/updates InRelease

    Hit:8 https://openmediavault.github.io/packages usul InRelease

    Hit:9 http://httpredir.debian.org/debian buster-backports InRelease

    Err:10 http://debian.serverspace.co.uk/debian buster InRelease

    Could not connect to debian.serverspace.co.uk:80 (130.180.200.18), connection timed out

    Err:11 http://debian.serverspace.co.uk/debian buster-updates InRelease

    Unable to connect to debian.serverspace.co.uk:http:

    Reading package lists... Done

    W: Failed to fetch http://debian.serverspace.co.u…an/dists/buster/InRelease Could not connect to debian.serverspace.co.uk:80 (130.180.200.18), connection timed out

    W: Failed to fetch http://debian.serverspace.co.u…/buster-updates/InRelease Unable to connect to debian.serverspace.co.uk:http:

    W: Some index files failed to download. They have been ignored, or old ones used instead.


    system is connected to the internet I have run pings to my router and internet IP addresses


    Any Ideas?

  • The Err and the W: say that the site is unreachable, the site could be down or the route to the site could be down, you have to wait until it's resolved.


    EDIT: Just tried a windows tracert on the ip address and it just times out.


    What's the output of cat /etc/apt/sources.list this is the output of my OMV5 VM;

  • Results of cat /etc/apt/sources.list


    cat /etc/apt/sources.list

    #


    # deb cdrom:[Debian GNU/Linux 10 _Buster_ - Official Snapshot amd64 LIVE/INSTALL Binary 20200325-17:27]/ buster contrib main non-free


    #deb cdrom:[Debian GNU/Linux 10 _Buster_ - Official Snapshot amd64 LIVE/INSTALL Binary 20200325-17:27]/ buster contrib main non-free


    deb http://debian.serverspace.co.uk/debian/ buster main non-free contrib

    deb-src http://debian.serverspace.co.uk/debian/ buster main non-free contrib


    deb http://security.debian.org/debian-security buster/updates main contrib non-free

    deb-src http://security.debian.org/debian-security buster/updates main contrib non-free


    # buster-updates, previously known as 'volatile'

    deb http://debian.serverspace.co.uk/debian/ buster-updates main contrib non-free

    deb-src http://debian.serverspace.co.uk/debian/ buster-updates main contrib non-free


    # This system was installed using small removable media

    # (e.g. netinst, live or single CD). The matching "deb cdrom"

    # entries were disabled at the end of the installation process.

    # For information about how to configure apt package sources,

    # see the sources.list(5) manual.

  • Results of cat /etc/apt/sources.list

    You need to edit that file, I know how I would do it having a usable copy/output of someone else's but I'm not sure if that's the correct way to do it.


    ryecoaaron the OP's sources list is failing to get updates, I have posted mine from my test VM which works, if the OP were to delete the content of his own then just copy and paste mine then save the file then run omv-aptclean would that resolve his problem.

  • the OP's sources list is failing to get updates, I have posted mine from my test VM which works, if the OP were to delete the content of his own then just copy and paste mine then save the file then run omv-aptclean would that resolve his problem

    The sources you posted should work for anyone. They are the same as mine.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Do you actually have the file? It is located as /usr/sbin/omv-aptclean


    Is /usr/sbin/ in your path?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Please don't paste an ls listing of hundreds of filenames. It's not helpful.


    Run these commands as root:


    Code
    updatedb
    locate omv-firstaid
    locate omv-aptclean

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • If you are running the commands as the root user and they are not found your machine is hosed. Got backup?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Nope! that will teach me!. in fairness I was still adding stuff to portainer. was planning on creating a backup but the update got me!


    if I run

    apt-get install --reinstall openmediavault


    would that keep all my settings portainer and omv-extra etc....

  • Running apt-get install --reinstall openmediavault can't hurt anything. But it might not help either. Do you have the apt-get or apt commands, or are they missing too?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!