Unable to open any Web Page in admin panel containing system information

  • Every time I try to connect to OMV Web Panel and go either to Dashboard or System Information, nothing happens (Dashboard on first load opens but has no system information).


    Web console errors are:


    Code
    Failed to load resource: the server responded with a status of 500 (Internal Server Error)

    and

  • Code
    {
    "response": null,
    "error": {
    "code": 0,
    "message": "Failed to execute command 'export PATH=\/bin:\/sbin:\/usr\/bin:\/usr\/sbin:\/usr\/local\/bin:\/usr\/local\/sbin; export LANG=C.UTF-8; hostname --fqdn 2>&1' with exit code '1': hostname: Name or service not known",
    "trace": "OMV\\ExecException: Failed to execute command 'export PATH=\/bin:\/sbin:\/usr\/bin:\/usr\/sbin:\/usr\/local\/bin:\/usr\/local\/sbin; export LANG=C.UTF-8; hostname --fqdn 2>&1' with exit code '1': hostname: Name or service not known in \/usr\/share\/php\/openmediavault\/system\/process.inc:182\nStack trace:\n#0 \/usr\/share\/php\/openmediavault\/system\/net\/dns.inc(60): OMV\\System\\Process->execute(Array)\n#1 \/usr\/share\/openmediavault\/engined\/rpc\/system.inc(349): OMV\\System\\Net\\Dns::getFqdn()\n#2 [internal function]: Engined\\Rpc\\System->getInformation(NULL, Array)\n#3 \/usr\/share\/php\/openmediavault\/rpc\/serviceabstract.inc(123): call_user_func_array(Array, Array)\n#4 \/usr\/share\/php\/openmediavault\/rpc\/rpc.inc(86): OMV\\Rpc\\ServiceAbstract->callMethod('getInformation', NULL, Array)\n#5 \/usr\/sbin\/omv-engined(537): OMV\\Rpc\\Rpc::call('System', 'getInformation', NULL, Array, 1)\n#6 {main}"
    }
    }
  • Content of /etc/hostname is srv-omv.local


    The web interface shows srv-omv.multi.box as the Domainname.


    I renamed the Domainname. Should I change it back as I don't really need it to be a specific value?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!