PLEX Hardware Transcoding (HW) Docker container NVIDIA OMV5

  • Hi All,


    First time poster, i usually try my hardest to fix thing myself exhausting all options but this time i'm stumped.


    So after much googling and headache i managed to install the NVIDIA Drivers and i believe all is working but it doesnt seem the Nvidia GPU is being passed through to PLEX.

    PLEX transcodes fine on the CPU. i follwed this thread How to setup Nvidia in Plex docker for hardware transcoding which thanks to tama777 was very helpful.


    If someone could review my setup and let me know of some things to check it would be greatly appreciated.


    My install: OMV5 Linux Anton.local 5.6.0-0.bpo.2-amd64 #1 SMP Debian 5.6.14-2~bpo10+1 (2020-06-09) x86_64

    Command: docker run --gpus all nvidia/cuda:10.0-base nvidia-smi works i think.

    PLEX Container details. Runtime=nvidia by default as i have edited nano /etc/docker/daemon.json


  • Did you read up on the docher hub entry for plex?


    Quote

    Nvidia

    Hardware acceleration users for Nvidia will need to install the container runtime provided by Nvidia on their host, instructions can be found here:


    https://github.com/NVIDIA/nvidia-docker


    We automatically add the necessary environment variable that will utilise all the features available on a GPU on the host. Once nvidia-docker is installed on your host you will need to re/create the docker container with the nvidia container runtime --runtime=nvidia and add an environment variable -e NVIDIA_VISIBLE_DEVICES=all (can also be set to a specific gpu's UUID, this can be discovered by running nvidia-smi --query-gpu=gpu_name,gpu_uuid --format=csv ). NVIDIA automatically mounts the GPU and drivers from your host into the plex docker.

    I can't see from your screenshots if you have the --runtime=nvidia set. To be honest I wouldn't know where to put it in portainer, without looking it up.


    Greetings

    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Thanks for the reply David.

    Quote

    I can't see from your screenshots if you have the --runtime=nvidia set. To be honest I wouldn't know where to put it in portainer, without looking it up.

    When setting up the container there is a runtime tab (screenshot) I'm guessing this is where I put it but it also defaults to NVIDIA, I'm guessing since I edited the daemon.json file.

    Quote

    Did you read up on the docher hub entry for plex?

    Yeah, I have referred to it seems like I have everything covered. It just doesn't seem to work. Must be missing something.


    Maybe I'll try create the container from commandline

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!