How to set up TVHeadend in Portainer

  • Hello from germany,


    i have yesterday my NAS completly ne installed from scratch. now i´m stucking on the new features in OMV, especialy 'Portainer'


    I'm trying to install TVHeadend to use my TVCard hardware. Here you can see how fare i´ve become. My Problem is the "optional" arguments. I created the 2 directorys for config and recordings, but i´m getting a falure response


    error message:

    Deployment error Error response from daemon: create path to data: "path to data" includes invalid characters for a local volume name, only "[a-zA-Z0-9][a-zA-Z0-9_.-]" are allowed. If you intended to pass a host directory, use absolute path


    The other Optional argument withe the RUN_OPTS, what i´m suposed to write there?


    I hope anyone can help. I tried to find a tut in the web, but all of them are for the old docker in OMV4. No one is showing portainer.


    Thanks in advance for your time and help. Stay healty and safe.


    Matt

  • I hope anyone can help

    yeah obvious really you have;


    - path to data:/srv/dev-disk-by-label-XPGNVMe1TB/NVMe1TB/TVHeadend/config

    - path to recordings:/srv/dev-disk-by-label-XPGNVMe1TB/NVMe1TB/TVHeadend/recordings


    it should be


    /srv/dev-disk-by-label-XPGNVMe1TB/NVMe1TB/TVHeadend/config :/config


    /srv/dev-disk-by-label-XPGNVMe1TB/NVMe1TB/TVHeadend/recordings :/recordings


    red = host blue = container


    hence your error; outside -> inside

    Raid is not a backup! Would you go skydiving without a parachute?

  • geaves


    thanks for the tipp. T tried:



    Ertror Message: "Deployment error Error response from daemon: invalid mode: /config"

  • geaves


    this solves the problem with the path. Now is there another.


    Message:

    eployment error Error response from daemon:error gathering device information while adding custom device "/dev/dvb": no such file or directory


    There is a DD Cine S2 V7A card on the board and before under OMV 4 she was running well.


    I'm running on a X11SCA-F mainboard and the TV card is on PCH SLOT2 PCI-E 3.0 X4. Is it possible that, because i have a new NVMe Card on M2-M1 and this two are sharing the connetion, the mainboard wont finde the DVB Card?

  • I don't use it, but if it worked on 4 what setting did you add/use to get it to work because if it worked in the docker plugin it will work in portainer, have a look at the information in linuxserver/tvheadend in docker hub.

    Raid is not a backup! Would you go skydiving without a parachute?

  • You maybe need to install the driver on your host system; https://manuals.digitaldevices.de/en/cine_s2_v7 Look under Driver Installation under Linux.


    It could also be that the device(s) are namend differently and not /dev/dvb and/or /dev/dri.


    Greetings

    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hi everybody,

    I am used to OMV4 so this is the first time for me to use Portenaire, I don't have eny idea to insert the code of the container's Tvheadend parameters !


    Thank you for your patience :)

  • Hi,

    After several attempts to create a new container "Tvheadend", without result.

    I tried to create the container by uploading the "Tvheadend" image by command line, after this :

    Contenair: add new contenair

    It work, but the problem is the path of config and recordings, they automatcly create in system and i don't how changet this, second, where put the "Extra arguments", finelly, it's the worst of all, i can't find the DVB device :!:

    What do you think about ?



  • Why didn't you jus use the docker-compose as he suggested? It's considerably easier and the way you're doing it is sort of backwards


    You can edit the container, and then go to volumes, and edit your paths there however.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Pourquoi n'avez-vous pas simplement utilisé le docker-compose comme il l'a suggéré ? C'est considérablement plus facile et la façon dont vous le faites est en quelque sorte à l'envers


    Vous pouvez modifier le conteneur, puis accéder aux volumes et y modifier vos chemins.

    Parce que j'ai eu du mal quand je l'ai déployé

    Un des nombreux messages !


  • First, put your docker-compose file in code box, as people can tell you what line the problem is on. That is the </> box in the formatting for a new post..


    In the above, your problem is line 25... you're missing a /


    Code
    - /srv/dev-disk-by-uuid-3a892938-56ab-48a6-a7cf-e5d65065b670/appdata/Tvheadend/config:config

    It should look like this..


    Code
    - /srv/dev-disk-by-uuid-3a892938-56ab-48a6-a7cf-e5d65065b670/appdata/Tvheadend/config:/config

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited once, last by KM0201 ().

  • Just like the message says, you have an invalid path in your config bind mount. You are missing the forward slash after the colon.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • Well, it works but without a device !


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!