Disable hibernate? (was: web ui suspend causes poweroff / systemctl suspend works)

  • Hi,

    I'm a long time user of OMV3/4 which has been chugging along nicely for ages - thanks for that!


    I've decided to give OMV5 a look.

    I have a fresh install of OMV5, fully upgraded, the only two "non-standard" parts would be

    1. I shrank the system drive a to use part of it as storage.

    2. added ethtool ... -wol to interfaces to enable wol.


    The problem I have is with suspend:

    - When clicking on "suspend" in the web ui the system instantly powers off. does not respond to wol, hitting the power button shows the system rebooting, not waking up from suspend.

    - When issuing a systemctl suspend command manually, the systems suspends fine, responds to wol, and wakes up.


    which command is is issued via the web ui? (is it different from systemclt suspend, why?)

    where can I change it? or is there a better way to fix this?


    many thanks!

  • Okay, I think I figured out what;s going on.


    OMV5 prefers hibernate over suspend:

    But, my system doesn't support WOL from hibernate/powerdown - only from suspend.


    So, the question now becomes:

    how can I disabled 'hibernate' ?


    thanks


    (oh yeah, I also found that you can set WOL from the webui - which will overwrite your edits anyway in /etc/.../interfaces)

  • undef

    Changed the title of the thread from “web ui suspend causes instant poweroff / systemctl suspend works” to “Disable hibernate? (was: web ui suspend causes poweroff / systemctl suspend works)”.
  • pm-suspend is the execute command. If you execute this via terminal, your system will suspend.


    I have the same issue. A can't wake up my system if suspended.


    If hibernate not working on your system then use shutdown. My system restart with WOL on shutdown. Shutdown is command: shutdown -h now. You can try this without to wait of autoshutdown.


    Now back to suspended issue:


    I found this: https://wiki.debian.org/WakeOnLan read PM-Utils Conflicts.


    I created file with disable_wol but it doesn't work. On suspend no WOL.


    I have no clue at the moment to fix this. I hope here is someone with more knowledge...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!