Ntfs and Sharedfolders

  • I noticed these two threads this morning this thread and this thread whilst they are not the same they are similar, so as I have an external usb dock and a plethora of assorted drives I thought I would experiment.


    This did not begin well, having connected the drive to W10 formatting it, creating some folders and copying some files we fell over when I connected to OMV, yes the drive was there, but nothing in File Systems. Down to the CLI wipefs -n showed the drive had zfs signatures on it, good old Windows doesn't wipe the drive just formats it, so wipe in OMV then back to Windows, gave the drive a label (nospaces) formatted to ntfs having selected gpt in disk management.


    Once finished created created 2 folders, 1 empty and 1 with a couple of films in it, copied another film directly to the drive (my films are in their own folders), unmounted form windows and connected to OMV.


    :thumbup: OMV now sees the drive and I can mount it, Access Right Management -> Shared Folders , create a share and name it NtfsDisk, set the path to / (the browse option does work and the folders I created in Windows were selectable) set permissions to everyone (it's easier to do this for testing), save , apply.


    SMB/CIFS -> Shares -> Add, from the dropdown select the shared folder previously created, set to only guests and set browseable, save, apply.


    Back to W10 -> Network open server and there is the newly created share, open the share and there are the folders that were either created or copied to the drive complete with their content, as well as the windows $recycle.bin and system volume information folder

  • Hello,
    I have similar problem. i have working disk in windows. just plug it to OMV and its shows in the disk list and filesystem list immediately. then i mount. and then share in samba.
    Now it accessible from windows machine in the network. i can not write anything to it but read from it.
    how should i make it writable?

  • when you mount disk in filesystem just use slash to access root folder. this way you can see every folder inside the disk.

    I actually say that in my post :) then your problem is a permission issue, install the reset permissions plugin and reset the permission on the share, then on SMB enable permission inheritance

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!