How to get a Bluetooth device in a container?

  • Hi,


    I tried to get my internal Bluetooth device working in my docker container. After installing some bluetooth packages i was able to find the device in the terminal:


    Code
    root@omv-nas:~# hcitool dev
    Devices:
    hci0 F0:XX:XX:XX:XX:XX


    Code
    root@omv-nas:~# sudo ls -l /sys/class/bluetooth | grep 1-8
    lrwxrwxrwx 1 root root 0 Jul 26 20:31 hci0 -> ../../devices/pci0000:00/0000:00:15.0/usb1/1-8/1-8:1.0/bluetooth/hci0
    root@omv-nas:~# cd /var


    So i tried to setup my container by using portioner in the device section (tab runtime & resources) with same entry in host & container "/dev/hci0"


    But when i try to start the container, an error message "device not found" is displayed. Also i'm wondering why "bluetoothctl" does not give any output when using the command "devices". Do y need any several bluetooth / usb drivers for the OMV standard installation?


    Does anyone has an idea how to get my BT Device working in the container?


    Best Regards


    Manuel

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!