'OMV_WEBGUI_ADMINGROUP_NAME' does not exist

  • Hi all,

    since last automatic update on my both server "admin" user can't see anything in the GUI and on one I've got the above error message while login.


    Is someone else is facing the same ?


    Any idea how to solve it ?


    rgds, Bruno;(

  • add admin and any user that you want to be admin to openmediavault-admin group.




    only valid for OMV5 , do not work on OMV4 because openmediavault-admin group do not exist.



    PD: if you can't log as admin on webGUI, you cad add user to groups on the shell, google how to add a user to existing group on debian.

  • In my case, it appears that the update had not completed - the file /etc/default/openmediavault.dpkg-new (which contains the environment variable) had not yet been applied: “sudo apt-get install -f” plus a reboot fixed it for me.

  • Okayyyyyyyyyyyyyyy, thansk guys or girls


    solution found and applied is :

    check dpk status :

    Code
    sudo dpkg --configure -a


    Killing all processes in progress :

    Code
    sudo killall apt apt-get

    then

    Code
    sudo apt-get install -f


    GUI is now accessible again with full rights.


    Thanks all.

  • WastlJ

    Added the Label resolved
  • After shutting down my server this morning and power it up again a few hours ago, i also received the same error.


    After executing the first command, i managed to log in to web GUI but when i try to make a change in the configuration, for example enable FTP connection, i receive the following error message:



    I understand that somehow, i upgraded to version 5.5.9-1, although i do not know how that happened since i have deliberately have decided to stay to two versions back



    Does anyone have any idea what is happening and how to fix this?

  • Hi,


    I have the same problem. Luckily I have another user which also cannot login to the gui, but I can login via putty with the second user. I added the second user to the groups "adm", "pi" --> but I cannot login via webgui.

    To login via webgui you need to have the group "openmediavault-admin", but this groups doesn't exist anymore.


    How can i gain access again via webgui?

  • Group must exist on OMV5, perhaps do you have OMV4?

  • macom: I tried the command but it says "usermod: group 'openmediavault-admin' does not exist"

    raulfg3 : I definetely installed OMV 5


    I really hope that I don't have to install everything from scratch... any other help?

  • I ran omv-update but the result was the following:


    Code
    $ omv-update
    Reading package lists... Done
    E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
    E: Unable to lock directory /var/lib/apt/lists/
    W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
    W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)


    The User Christian is in the following groups, so I actually should have the permissions:

    Code
    Christian : users adm sudo pi ssh spi gpio docker


    The sesond command showed this:


    Code
    $ pkg -l | grep openmedia
    -sh: 9: pkg: not found


    And I still am not able to make add users to the admin-group:

    Code
    $ usermod -a -G openmediavault-admin admin
    usermod: group 'openmediavault-admin' does not exist
  • Of course, I forgot myself the "sudo"... 😒


    So the output of sudo dpkg -l | grep openmedia ist the following:


    But the update showed some errors at the end, maybe this will help?


  • Yes, the file /var/log/salt/minion is there.


    I also found a folder "omvbackup" and it looks, that the system did a backup in march:

    If there is no way to repair the system maybe you could help me to reset it to the last backup? Don't know how I made that backup...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!