Nextcloud and Airsonic with Letsencrypt: Airsonic redirect to Nextcloud always!

  • Hi at all!


    In my OMV, I installed Nextcloud (following the macom guide - [How-To] Nextcloud with Letsencrypt using OMV and docker-compose) and Airsonic.


    Airsonic however does not use Letsencrypt, so I tried to change its configuration.


    First of all, I removed LetsEncrypt service from the Nextcloud stack and created a container only for it.

    I added LetsEncrypt container network the to the containers of the Nextcloud stack (redis, nextcloud and nextcloudDB).

    Nextcloud continues to work properly.


    So, I tried to follow the same steps to insert LetsEncrypt on Airsonic.

    • I removed 4040 port forwarding from the router, leaving only ports 80 and 443 rules.
    • I modified the Airsonic stack by inserting the variables CONTEXT_PATH and JAVA_OPTS and remove port 4040
    • I removed from airsonic container the bridge network and added the LetsEncrypt network

    I then moved on to setting up the proxy:


    cd /srv/dev-mydisk/appdata/letsencrypt/nginx/proxy-confs


    cp airsonic.subfolder.conf.sample airsonic.subfolder.conf


    and I modified the .conf file in this way:


    Now, if I call:


    Someone can help me?

    Thanks!

  • I can't answer for letsencrypt specifically (I'm personally using Traefik), but when I get a 502 Bad Gateway, that usually means for me that either the container behind the reverse Proxy is not running, or I got some misconfiguration not pointing correctly to the internal service.


    Greetings

    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • I'm a bit late, but i use airsonic behind nginx proxy (swag container), i upstream to http and port 4040.


    This is the standard proxy conf file for airsonic (with subdomain instead of domain subfolder) :

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!