OMV Volumes verkleinern/vergrößern

  • Vielen Dank, da schaue ich nach. Ich muss wieder mal etwas fragen.

    Ich habe nun gesagt bekommen wie ich mein Volume NAS verkleinern kann und mein Volume TimeMachine vergrößern kann. Dazu muss ich wohl auf der CLI folgendes eingeben:

    Code
    lvreduce -L 15T --verbose --resizefs /dev/NAS/NAS

    Danach kann ich wohl per Schieberegler in OMV wieder die Größe neu einstellen.

    Zuvor muss jedoch das Laufwerk NAS (/dev/dm-1/) aushängen.

    Jetzt meine Frage(n):

    Wie mache ich es richtig bzw. was muss ich beachten?

    Ich muss zuerst meine freigebenden Ordner entfernen, oder kann ich direkt aushängen unter Dateisysteme?

    Muss ich vorher Docker Container (wie NextCloud, Plex, etc.) stoppen?


    Vielen Dank

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • Bin hier für jede Hilfe dankbar 🙏

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • I would unmount from the command line. You will have to stop services using the filesystem in order to unmount it though. The easiest way to do this is install systemrescuecd from omv-extras and boot into it. Then you know the filesystem isn't mounted or in use.

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ich muss zuerst meine freigebenden Ordner entfernen, oder kann ich direkt aushängen unter Dateisysteme?

    Wenn du dem Rat von ryecoaaron folgst und systemrescuecd bootest, dann brauchst du in OMV gar nichts ändern. systemrescuecd booten -> Deine Volumes wie gewünscht anpassen und danach wieder OMV booten. Damit sollte es dann erledigt sein und die brauchst nichts in OMV herumzufummeln. Das Dateisystem kannst du nämlich nur aushängen, wenn es keine Referenzen (shared folder, shares usw.) darauf gibt. Das spart so eine Menge Arbeit, wenn man im Anschluss nicht wieder alle Shares auf´s Neue einrichten muss.

    OMV 3.0.100 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • thanks a lot ryecoaaron and cabrio_leo:

    So I have to do the following steps:

    1. boot into SystemRescueCD by clicking the blue button (I have already clicked install). Then the system boot to a promt?


    2. Wait a couple of seconds and start my terminal to connect via SSH to my NAS as root.


    3. type in:

    Code
    lvreduce -L 15T --verbose --resizefs /dev/NAS/NAS

    for 15TB, the promt folder where I type this in does not matter?


    4. Waiting until finished.


    5. reboot with the command.

    Code
    reboot


    6. After the reboot my NAS restarts with OMV (again)?


    Thanks a lot

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

    Edited once, last by Beamformer ().

  • Yes, that is what you need to do. It is possible your LV name will be different or have a different path. If it is not at /dev/NAS/NAS, look in /dev/mapper/.

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I tried to start the SystemRescueCD, but nothing happened. When I click start, the following screen remains.

    Plex and the OMV GUI is still available!

    Why? Do I need to to something other?

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • You have manually restart the machine after pressing that Start button. It will then reboot into the SystemRescueCD.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • thanks.

    since ten minutes the same screen

    I installed a screen on the NAS - no output and not reachable.

    hmmm

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • I already have - nothing is on the display and OMV still says it will reboot now...

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • Reboot the machine yourself.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • It works - thank you very much.

    I had some trouble with a error message (broken pipe) and I had to restart the NAS with the power button but it seems to work


    Now I can to give my Volume TimeMachine more storage, e.g. 2 or 3 TB.


    I think we can close this thread. Thank you very much!

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

    Edited 3 times, last by Beamformer ().

  • Beim starten meines NAS habe ich oft Probleme damit das ich im "rescue mode" bin und strg+D drücken muss um booten zu können, das ist natürlich doof, da standardmäßig weder eine Tastatur n och ein Monitor dran hängt.


    Kann es sein das dies noch vom systemrescuecd booten kommt? Komischerweise kommt die Meldung nicht immer, sondern nur jedes 2te Mal. Kann ich hier einfach exit eingegeben


    Allgemein habe ich beim starten Probleme, eigentlich möchte ich automatisiert jeden Tag starten, dies gelingt mir allerdings bis dato weder per Plugin noch per Bios/UEFI


    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • Hat da jemand evtl. einen Tipp für mich?

    Wenn ich mich einlogge und dann exit eingebe kommt es beim Neustart wieder :-(

    Als ich den NAS in Betrieb genommen habe, habe ich Debian mehrmals installiert oder versucht zu installieren:

    D.h. ich habe beim Start die Auswahl mehrerer Kernels, kann das ein Problem sein?

    Vielen Dank

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

    Edited once, last by Beamformer ().

  • macom Danke, eben eingestellt, jetzt bin ich mal gespannt ob die Kiste morgen früh hoch fährt, ich gebe Bescheid.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

  • macom leider hat das nichts gebracht, heute morgen kam beim Starten wieder dasselbe :-(

    Nachdem root Passwort habe ich 'systemctl default' eingegeben und das letzte Mal 'exit'.

    Leider brachte das auch alles nichts.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

    Edited once, last by Beamformer ().

  • Jawoll, mit OMV4 hat einer dasselbe Problem und hat OMV einfach neu installiert und es war wohl weg.

    Geht das so einfach ohne das der NAS (die Datenfestplatten, das LVM) zerschossen werden?

    Quelle: https://www.technikaffe.de/for…startet-im-emergency-mod/

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, SALCAR Premium Ladegerät 12V 6A - 72W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Zerone 2 Port PCI-E SATA Karte, PCI Express SATA 3.0 Controller 6 Gbit/s PCIe Karte SATA III

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!