Stromsparen mit OMV, Autoshutdown, Standby und WakeOnLan

  • Ich würde gerne "die nächste Baustelle" angehen und zwar das Stromsparen. Der NAS soll im idle in den deep Standby bzw aus gehen und per WakeOnLAN wieder angehen sobald dieser gebraucht wird. Also nicht nur die HDDs in standby schicken sondern komplett.

    Jetzt habe ich die Option unter "Autoshutdown" Allerdings fährt nichts herunter. Wie kann ich denn zusätzlich Infos anschauen wie z.B. Auslastung, CPU-Temperatur und co.?

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Jetzt habe ich die Option unter "Autoshutdown" Allerdings fährt nichts herunter.

    Autoshutdown hat ein sehr gutes Logging. Da wird bis ins kleinste Detail erklärt, was das NAS am herunterfahren hindert. Das Standard Logging kann über einen Schalter noch erweitert werden. Hier im readme werden die verschiedenen Einstellungen erklärt.


    Ich persönlich arbeite u.a. mit der pinglist. Da hat man mehr Möglichkeiten, als mit dem ip-Range. Es sind alle Rechner eingetragen, die das NAS am herunterfahren hindern, wenn sie an sind.

    OMV 3.0.100 (Gray style)

    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1) - Fractal Design Node 304 -

    3x WD80EMAZ Snapraid / MergerFS-pool via eSATA - 4-Bay ICYCube MB561U3S-4S with fan-mod

  • Danke für den Tipp. Ich möchte nachts gerne den NAS ausschalten um Strom zu sparen und morgens wieder an. Jetzt habe ich mal ins log file geschaut warum nichts ausgeht. Leider kann ich nicht viel damit anfangen. Unglücklicherweise kann ich die log Datei nicht öffnen nachdem ich diese mit dem MidnightCommander auf mein freigegebenes Laufwerk kopiert habe, daher habe ich die letzten Zeilen raus kopiert. Reicht das?

    Die meisten Einstellungen habe ich auf Standard gelassen. Die 50er IP ist die vom Apple TV, sprach wenn ich mit diesem schaue soll der NAS anbleiben, sonst ausgehen.




    /var/log/autoshutdown.log 3589760/3506K 100%

    Sep 26 22:56:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 22:59:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 22:59:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 22:59:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 22:59:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 22:59:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 22:59:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:02:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:02:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:02:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:02:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:02:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:02:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:05:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:05:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:05:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:05:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:05:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:05:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:08:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:08:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:08:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:08:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:08:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:08:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:11:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:11:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:11:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:11:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:11:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:11:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:14:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:14:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:14:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:14:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:14:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:14:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:17:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:17:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:17:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:17:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:17:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:17:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    Sep 26 23:20:08 debian root: autoshutdown[19396]: INFO: '------------------------------------------------------'

    Sep 26 23:20:08 debian root: autoshutdown[19396]: INFO: ' new supervision cycle started - check active hosts or processes'

    Sep 26 23:20:08 debian root: autoshutdown[19396]: INFO: ' Checking the time: stay up or shutdown ...'

    Sep 26 23:20:08 debian root: autoshutdown[19396]: INFO: ' System is in Stayup-Range. No need to do anything. Sleeping ...'

    Sep 26 23:20:08 debian root: autoshutdown[19396]: INFO: ' Sleeping until 1:55 -> 0 seconds'

    Sep 26 23:20:08 debian root: autoshutdown[19396]: INFO: ' sleep for 180s.'

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Mittlerweile habe ich es geschafft das OMV selbstständig herunter fährt. Nun habe ich gelesen dass es ein weiteres Plugin zum automatischen hochfahren benötigt. WOL, leider ging dies nicht und jetzt habe ich ein anderes Problem. Und zwar die Geschwindigkeit

    Mit 10 Mbit geht gar nichts mehr. Nach tagelanger Recherche stellte sich heraus das die wohl irgendwie an der WOL Funktion liegt. Also deinstalliert, neu gestartet und gut war es. ABER: nach einem Neustart wieder das gleiche, alles lahm und das Plugin war wieder da. Wieder deinstalliert und neugestalten. Jetzt ist wieder alles lahm aber das Plugin ist deinstalliert. Was nun? So geht nichts mehr.

    Vielen Dank.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Die maximale Geschwindigkeit beträgt nur 1mb/s

    Und das muss irgendwie mit der Funktion wake on lan bzw.. der sleep Funktion zusammenhängen, welche ich jetzt aber deaktiviert habe.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Also wenn ich das Plugin Autoshutdown deaktiviere habe ich wieder Gbit Geschwindigkeit.

    Hat mir hierzu jemand Rat wie ich nun fachgerecht in den Standby gehen kann und morgens wieder aufwache?


    Vielen Dank

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

    Edited 2 times, last by Beamformer ().

  • Also (nachts) in den Standby gehen geht mit dem Plugin autoshutdown. Allerdings schaffe ich es nicht mit rtcwake wieder morgens z.B. um 9 Uhr den NAS automatisch wieder anzuschalten.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Also leider schaffe ich es bis dato immer noch nicht den NAS morgens um 9:00 Uhr automatisch aufwachen zu lassen.

    Ich habe ein ASRock J4105-ITX und dort habe ich im UEFI die Option PCIE Devices Power on auf aktiviert gestellt, unter OMV5 habe ich bei der Netzwerkschnittstelle 'Wake on lan' aktiviert und das Plugin 'WOL' installiert. Hier stelle ich bei Rtcwake auf 'Nicht in Ruhezustand versetzen, Nur RTC Wake up time wird gesetzt' und stelle darunter dann 9 ein, wenn ich dann auf Bereitschaft klicke lädt es bis zum jüngsten Tag (ohne Bestätigung). Die Einstellungen werden aber wohl gespeichert, zumindest stehen diese beim nächsten Aufruf noch da. Jetzt weiß ich auch nicht was da schief läuft, gelesen habe ich dass damit wohl viele Probleme auftreten (können). Per FritzBox GUI kann ich den NAS aufwecken, allerdings habe ich dann wieder 10MBit/s Geschwindigkeit :-( Prinzipiell scheint wohl also schon mal zu funktionieren.

    Auch wenn ich im UEFI einstelle das der NAS täglich um 09:00Uhr angehen soll funktioniert nicht.

    Hat mir noch jemand einen Rat?

    Vielen Dank

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

    Edited 3 times, last by Beamformer ().

  • Weiß denn keiner mehr was oder benötigt ihr weitere Infos?

    Das Teil will einfach nicht so wie ich will, der NAS fährt runter aber nicht mehr hoch, wenn ich ihn per Hand morgens einschalte kommt die Meldung (sehr oft): ata5: softreset failed (device not ready) & ata6: softreset failed (device not ready) mehrmals bis er sich wieder schlafen legt. Und seit ich suspend statt hibernate mache kann ich ihn per FritzBox GUI auch nicht mehr aufwecken.

    Bin für jeden Tipp dankbar, frohe Weihnachten.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • ata5: softreset failed (device not ready) & ata6: softreset failed (device not ready)

    Für mich deutet das auf ein Treiberproblem hin. Hast Du mal in einem Linux forum nach Problemen mit deiner Hardware (Motherboard, eventuell DiskController, HDD, Netzwerkkarte/chip) beim "Resume aus Standby" gesucht?
    Da hier keine Details der Hardware und OS genannt sind, ist es nur ein "Schuss ins Blaue"

    omv 5.6.13-1 (usul) on RPi4/4GB with Kernel 5.10.17 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • mi-hol vielen Dank für Deine Antwort.

    Ich habe in der Signatur jetzt meine komplette Hard- und Software hinterlegt, danke für den Hinweis.

    Das habe ich noch nicht gemacht, ein Treiberproblem würde mich jetzt wundern weil der NAS ja sonst läuft, das kommt ja nur wenn ich ihn per Knopf aufwecke weil dieser nicht automatisch aufwacht.

    Aber ich werde dies noch nachholen, danke für den Tipp.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • der Treiber muss beim Resume, die Kommunikation mit den Geräten (zB HDD) wieder neue starten, dass das nicht immer klappte war ein häufiges Treiberproblem das die Zeitschrift c't oft thematisiert hat.

    laut AsRock web seite 'Storage

    - 2 x SATA3 6.0 Gb/s Connectors, support NCQ, AHCI and Hot Plug

    - 2 x SATA3 6.0 Gb/s Connectors by ASMedia ASM1061, support NCQ, AHCI and Hot Plug'

    'Zerone 2 Port PCI-E SATA Karte' ist noch eine zusätzliche DiskController zu welchem Zweck?

    Die Karte wuerde ich als erstes eliminieren und die 2 HDD auf die 2 Ports mit ASMedia ASM1061 stecken

    omv 5.6.13-1 (usul) on RPi4/4GB with Kernel 5.10.17 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • ok, verstehe, dachte nur weil es sonst ja auch (meistens) geht.

    Die PCI-E Sata Karte habe ich für die Systemplatte, weil ich nochmals 2 WD red ans Board anschließen will und das Board hat nur 4 Anschlüsse und hier sollen die Datenplatten ran.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • Es gilt wie fast immer "nur Versuch macht klug"


    Gibt es BIOS?driver updates von ASRock?

    Mich wundert, dass das Board nicht im breiten Handel ist, das ist kein gutes Zeichen

    omv 5.6.13-1 (usul) on RPi4/4GB with Kernel 5.10.17 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • gute frage, als ich mal gelesen habe das dies bei einem Fehlversuch gleich alles abschießt, habe ich mich nicht weiter damit beschäftigt. Ich habe das im Sommer einfach nach einer Anleitung gebastelt: https://www.elefacts.de/test-5…x_sata_im_mini_itx_format

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • lauter Amazon Affiliate Links in der und weiteren Anleitungen, ein Schelm der Böses dabei denkt

    omv 5.6.13-1 (usul) on RPi4/4GB with Kernel 5.10.17 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • hmmm ok, die Anleitung sah eigentlich ganz gut aus und soweit funktioniert auch alles - aber ich habe auch schon den ASRock Kontakt kontaktiert und da kam gar nichts.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

  • was mir noch einfällt, während der Fehlermeldungen aus Post #9 ist der NAS erreichbar (man kann zumindest vom Plex Server Inhalt streamen), geht dann aber nach wenigen Minuten wieder in den StandBy.

    OMV 5.5.23-1 (Usul), Linux 4.19.0-13-amd64, Debian

    ASRock J4105-ITX, Crucial RAM CT2K4G4SFS824A 8GB (2x4GB) DDR4 2400 MHz CL17, 2x12TB WD red, PicoPSU-90 12V DC-DC ATX Mini-ITX 0-90W Netzteil Power Supply, Ladegerät 12V 10A - 120W - Netzteil, Systemplatte: SanDisk SSD PLUS 120GB Sata III, Cooler Master Elite 120 Advanced, für die Systemplatte: Sata to usb

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!