Can't get network working except initial NIC

  • I'm excitedly setting up my OMV server and for the most part, things have gone without incident. I did have the Grub boot issue but it's fixed. Now I've hit another snag.


    My server has an Intel Quad NIC and when I set up OMV I did it plugged into enp1s0f0. I really wanted it in enp1s0f1, but it wasn't showing a link light for some reason. Anyway, got it up and entered the interface.

    I've since enabled interfaces enp1s0f0-enp1s0f3 with the intention of segmenting my containers and VMs as I do on Unraid on my other server. He's what I'm shooting for:


    enp1s0f0 - future, maybe bond or admin VLAN

    enp1s0f1 - 192.168.60.0/24,VLAN60 (GUEST)

    enp1s0f2 - 192.168.70.0/24,VLAN70 (IOT)

    enp1s0f3 - future, maybe bond


    For testing I've tried setting enp1s0f1 with IPv4 disabled but with a VLAN60 child that has IPv4 enabled, which is basically how it works on Unraid. I've left IPv4 enabled on the enp1s0f2 parent and set up VLAN70 to similarly get an IPv4 just in case that's the way it works here as a test. All IPs are assigned by DHCP.


    While I now get a link light when I plug in the cables to enp1s0f1 and enp1s0f2, the interfaces to not get an IP. I've tried tagging and untagging the switch ports and nothing. Can anybody tell me what's going on here?

  • So in further testing I tried enp1s0f3 , as it was configured exactly like port enp1s0f0 (no VLANs) and it doesn't work either. If I pop the cable in enp1s0f0 then I get an IP and I can access the interface. I tried running omv-firstaid to set network config as well and though it completed with no errors it still operates the same way.
    I think that's it for me. I'd really thought OMV would be best for this but if I can't even set up the networks and trust it to keep the configuration valid then I certainly can't put all the things I wanted to on it. I'm bummed, but maybe I can revisit whenever OMV 6 comes out.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!