Raspberry Pi : "Failed to read from socket: Connection reset by peer" at the end of the plugins / updates installation and uninstallation

  • Hallo,


    I have been getting the above mentioned error during install / uninstall of some plugins and updates.

    Specifically if the have "Updating locale files.....". If this is missing, then I get no error.



    Here is an example of installation error:


    Reading package lists...

    Building dependency tree...

    Reading state information...

    The following NEW packages will be installed:

    openmediavault-apttool

    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

    Need to get 15.1 kB of archives.

    After this operation, 186 kB of additional disk space will be used.

    Get:1 https://dl.bintray.com/openmediavault-plugin-developers/usul buster/main armhf openmediavault-apttool all 3.6 [15.1 kB]

    Fetched 15.1 kB in 2s (6055 B/s)

    Selecting previously unselected package openmediavault-apttool.

    (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 59358 files and directories currently installed.)

    Preparing to unpack .../openmediavault-apttool_3.6_all.deb ...

    Unpacking openmediavault-apttool (3.6) ...

    Setting up openmediavault-apttool (3.6) ...

    Updating configuration database ...

    Processing triggers for openmediavault (5.5.6-1) ...

    Updating locale files ...


    >>> *************** Error ***************

    Failed to read from socket: Connection reset by peer

    <<< *************************************

    Updating file permissions ...

    Purging internal cache ...

    Restarting engine daemon ...

    Done ...



    Uninstallation error :


    Invalid RPC response. Please check the syslog for more information.


    Error #0:

    OMV\Rpc\Exception: Invalid RPC response. Please check the syslog for more information. in /usr/share/php/openmediavault/rpc/rpc.inc:187
    Stack trace:
    #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Exec', 'getOutput', Array, Array, 3)
    #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #2 {main}

    In any case the system seems to working ok. Any ideas on this errors?

  • That isn't a real error. It is nginx and/or omv restarting causing a short blip in communications. Nothing to worry about.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • That isn't a real error. It is nginx and/or omv restarting causing a short blip in communications. Nothing to worry about.

    Thank you for the information. You saved me for deployment No 5 in 24hours...... I was going crazy about this cause I could not exactly determine the cause not to mention that there actually no errors in the logs.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!