Nextcloud and Ubiquiti UMD Pro not working

  • I have been running OMV since its release and am now up to version 5. I recently put a Ubiquiti UDM Pro in my network to replace my Untangle firewall - and now I am pulling out my hair trying to get NextCloud to work again. I have tried every install/config out there I could find - and I always run into the same issue. Everything installs just fine (whether I am trying just nextcloud, or a docker stack with Letsencrypt, NextCloud, Mariadb, etc) and I am getting the same problem.


    Everything installs fine, but once installed, I cannot hit the Nextcloud admin page from my local lan (no matter what port I use) and if I try to hit it via my DDNS (using DuckDNS) and port forwarding on the UDM Pro - anything with 443 goes to my UDM Pro dashboard, and anything else (like port 444 redirected to my Nextcloud IP:444) fails.


    I do have a ticket in with Ubiquiti to see if there is a way to change the port on the UDM Pro, and I have my OMV set to port 81 - so that works just fine. This has been driving me crazy the last month trying to get this working again.


    Anyone have any suggestions?


    TIA


    George

  • Did you take a look here?


    https://help.ui.com/hc/en-us/a…ation-and-Troubleshooting


    Greetings

    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • I have played a lot with the UDM Pro's Port Forwarding rules - and never got it to work on this Nextcloud installation. The larger issue I have is I cannot even access the Nextcloud GUI from the LAN - and I have tried changing every .config and .php trouble shooting guide I could find. Still no luck ;-(

  • Can you show some overviews/log outputs of portainer for the nextcloud and LE container? Maybe even the config?


    Greetings

    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • I will try to get that info - with our new semester starting I have been busy getting labs ready, updating our Cisco curriculum to the new v7, and lots of other prep work.


    And now I have the fun experience of the UDM Pro that I manage 2000 miles took an auto update the other day - and now I cannot connect through the cloud dashboard. Lots of people having the same issue - with the WAN port and its ability to auto-negotiate - - requires an on-site fix - sigh....


    Thanks


    George

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!