WebGUI not working

  • As the title suggests, for no apparent reason, I can not access the webGUI through my browser. The server is clearly working, since I can SSH into it, NextCloud and Portainer are working fine and I'm able to access their webguis.

    This happened while I was mid way on configuring my NextCloud installation. Maybe this is the root of the problem?

    I have tried:

    -clearing my browser cache

    -accessing from another computer and my mobile phone -cleared "web interface cache" with omv-firstaid and (tried) changing the default port to 80.

    -checked that i have space on my OS disk (it's less than 2% full)

    -restarting both my server and my PC.


    All I get is the 503 error in chrome or that my website can't be reached.

    Checked on router and through ifconfig and my IP has not changed. (It's set to static via the router)

    I'm also forwarding my 80 and 443 ports.


    Server specs if they are helpful:

    Ryzen 2700x,

    Gigabyte B450 Aorus M,

    Asus GTX 1050Ti,

    500GB Crucial P1 nvme SSD,

    2x 5TB WD Red (linear),

    2x 3TB WD Red (mirror)


    If anyone has any idea, please let me know. If nothing else, is it possible to reinstall OMV without reinstalling NextCloud and re-doing my RAID setups?


    Thanks in advance,

    Cheers.

  • In the shell run omv-firstaid and Configure web control panel make sure the port is set to 80.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • Is some other service using the same port? Nextcloud?

    Nextcloud uses port 80, but I set my OMV to port 81. In set OMV to 80 only after I started troubleshooting. NextCloud (in docker) and OMV ran together just fine, the problem happened while I was configuring some unrelated stuff on NextCloud. Is there a way to check for sure that NC is not causing issues?

  • You cannot run two services on the same host port.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

    Edited once, last by gderf ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!