OMV Poweredge build!

  • Several months ago I decided to move up from a raspberry PI 3b with a usb SSD as my NAS solution to a full fledged commercial server, albeit used. I scoured ebay for days until I found several machines that balanced decent specs with a decent price. I submitted bids and offers on seveal different models before winning a "Dell Poweredge t310" circa 2011.


    Initial specs :

    Cpu : Intel Xeox x3430 @ 2.4 ghz quad core.

    Memory : 4gb ecc compliant ram

    Storage: 4x 1tb HDD drives configured in 2 RAID 1 striped volumes @ 1tb each controlled by a PERC 700 raid controller.

    1x 250gb HDD for os

    OS: Debian 10 running OMV 5.5.8-1 (USUL)

    I/O: 4x rear usb 2

    2x Embedded Gigabit lan

    1x VGA

    1x Serial

    2x Gigabit lan PCIe

    (Front) 2x usb 2

    (internal) 2x usb2


    So why 4 gigabit ports? Well when the unit arrived the two embedded ports refused to activate. I tried and tried for days to get a link established, mostly shooting in the dark, as this is my first taste of commercial grade hardware. So many more settings than on consumer grade. Bounced back and forth between UEFI settings, embedded NIC firmware settings, embedded PXE settings. nothing worked. Eventually contacted the seller and deemed the unit defective. The seller sent out a replacement PCIe dual gigabit card free of charge to make up for the defective part. (unit was listed as 100% fully working)


    Now that I have communication, its time for an OS!

    I would love to say that I loaded up a usb stick with OMV, plugged it in, and 20 minutes later I had a working server.... but id be lying. What followed was 2 days of wrestling with the PERC raid controller to set up my raid array, fighting with the server motherboard to even LET ME USE A USB OS LOADER, as it would prefer os to be loaded over the network. and then actually getting firmware for proprietary 10 year old dell server hardware to play nice with Debian.


    Holy cow was that an adventure. I wish I had video recorded the entire thing. I did eventually get all issues smoothed out. I still have 2 modules missing firmware, and what they are? no idea. They're listed but don't seem to actually exist and everything works fine now so they can remain a mystery. Now that all is running and in production I couldn't be happier with it. Transfer times are limited by the HDD its self, rather than the processing power of the Raspberry pi. The Xeon cpu never gets slowed down by this workload, even with multiple clients transferring multiple GB's at once. The gui is quick and responsive. IT JUST WORKS and I will never go back to consumer hardware for a full time server!

    Plus the case is fully lockable with a cool dell key.... so there's that.


    Thanks,

    Ricky

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!