Migrate BTRFS RAID from Synology/XPEnoloy

  • Hello community,


    after initially experimenting with OMV some time back on my raspberry pi (single client backup+airplay) I got ahold of a HP HomeServer which I used a while with macOS installed (local home photo-sharing) and later after I migrated my photo-library to iCloud with XPEnology.


    While the overall user experience is great the network read performance is subbar with any OS which I suspect the hacky XPEnology network drivers to blame for.

    Preparing an external OMV flash install (4 internal drives dedicated to RAID5) went fine and the RAID can be seen and mounted after some fiddling around. What does not work however are the BTRFS sub-volumes. Neither do they show up as sub-volumes using the Btrfs utils (though I might have gone wrong? Btrfs show /sub/volume/path ) nor there is any error when checking the filesystem. However they are listed as not accessible folders in their respected top level directors with wired permissions.

    Code
    ls -n /btrfs/volume
    drwxr-xr-x 1 502 20 12288 24 Aug 18:14 Folder_1
    drwx------ 1 502 20 16384 26 Aug 15:23 Folder_2
    drwxrwxr-x 6 0 80 192 10 Jul 00:28 Folder_3
    d????????? ? ? ? ? ? ? ? BTFRS_SUB-VOLUME_1
    drwx------ 1 502 20 16384 12 Apr 12:11 Folder_4
    d????????? ? ? ? ? ? ? ? BTFRS_SUB-VOLUME_2
    d????????? ? ? ? ? ? ? ? BTFRS_SUB-VOLUME_3
    d????????? ? ? ? ? ? ? ? BTFRS_SUB-VOLUME_4

    How may I mount them/add them to fstab to auto mount them?


    Best RastaFabi


    PS.: Booting back to XPEnology again I can access the volumes just like regular folders.

  • First of all, do U have a full data backup on an external hard drive or so? You should not do anything with raid before your data is safe! Furthermore RAID 5 and 6 on BTRFS are still mentioned unstable because of possible data corruption in case of power loss. You should be aware of that.

    Maybe it is a good idea to first do your BTRFS and RAID experiments on a VM. Subvolumes on your list really look weird. Something went really really wrong there. What are the exact steps you did so far?

  • The RAID mostly houses some replaceable files (movies, which I do not care to backup), ISO installers and so on. Additionally it serves as a local file exchange server, but as such only temporarily houses documents which are on the client computers anyway. It serves a cordless backup solution locally, though any computer backed up does has another wired backup anyway which is run on a less frequent basis.


    Regarding the steps I did:

    1. Setup everything as default using SynologyOS (XPEnology is more or less only a bootloder with some additional drivers chain loading a legit business grade Synology installation). - Running this way for months now with a reboot about every 2-3 months

    2. Power down and replace the SynologyOS USB with a VM made cloned (.vdi – .img – drive using dd) running OMV with the swap partition removed and the OMV-extras flash extension installed and fstab setup accordingly.

    3. Power up OMV and rename the Btrfs "volume" (raid appliance) from terminal using brtfs label as OMV cannot deal with blanks in the label

    4. realising that the sub volumes are not available and running Btrfs scrub to validate the fs as those folders/sub-volumes appeared as shown above. No errors found at all.

    5. Restarting from my Synology USB just to find that everything works fine as it is supposed to be.


    PS: Power-loss is no issue here, unlike for instance in the US. I experienced one once in my lifetime some chilling 17 years back or so.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!