Lost Raid. Now cant use drive.

  • Hello.

    OMV 4


    I had a Raid1 array with two drives. The array just disappeared. No crash, no reboot nothing. Just vanished.


    It had no data so I deleted the missing Raid. Started to make a new one but it would't work. Deleted that.

    Decided to just use the drives. Set the first drive up no problems. But the second one is busy in the system somehow and wont get past the create file system.


    I think it is still stuck in a half made array. I dont know where to look to delete that and release the drive. Anyone know the answer??


    Thanks for any help.

  • I had a Raid1 array with two drives. The array just disappeared. No crash, no reboot nothing. Just vanished.

    Are these USB devices

    But the second one is busy in the system somehow and wont get past the create file system.

    Have you wiped the drive Storage -> Disks -> Wipe on the menu

    Raid is not a backup! Would you go skydiving without a parachute?

  • Not USB.


    Drive in question is sdc1. Yes wiped the drive. then set up file system. OMV creates the file system but then stops with this error...


    Error #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; mkfs -V -t ext4 -b 4096 -m 0 -E lazy_itable_init=0,lazy_journal_init=0 -O 64bit -L 'nas3' '/dev/sdc1' 2>&1' with exit code '1': mke2fs 1.44.5 (15-Dec-2018)
    /dev/sdc1 is apparently in use by the system;
    will not make a filesystem here! in /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc:672
    Stack trace:
    #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMVRpcServiceFileSystemMgmt->{closure}('/tmp/bgstatusEt...', '/tmp/bgoutputqP...')
    #1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(688): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure), NULL, Object(Closure))
    #2 [internal function]: OMVRpcServiceFileSystemMgmt->create(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('create', Array, Array)
    #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'create', Array, Array, 1)
    #6 {main}


    Thank for any help.

  • Got my drive back.


    I found a file created by the make raid subroutine. /dev/md127

    I deleted that then rebooted OMV and bam... drive fully accessable again.


    Thanks for the help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!