Permission denied error on opening NFS mounted directory

  • So I'm trying to set up NFS, but for the life of me I can't figure out how to get it to mount properly. My plan is to follow this guide, but I figure I should make sure I can mount with `mount` first.


    My options on NFS are:

    Code
    subtree_check,insecure,anonuid=1000,anongid=100,no_root_squash

    I have the id flags in because I read that it doesn't work with different ids, and my clients are all Arch boxes.


    I'm mounting with:

    Code
    sudo mount -t nfs -o vers=4 server:/ /mnt/location


    I can mount fine, but when I run ls /mnt/server I get:


    Code
    ls: cannot open directory '/mnt/location/server': Permission denied


    What do I need to try?

  • I'm still struggling to get access, though: I keep getting permission denied errors when trying to access my share.

    Well you're getting further than I did I tried this on my W10 workstation, MS makes setup so difficult, but it still would not connect, but what I don't like about this is that it 'maps' a drive letter to the nfs share, that's fine on Linux, no something I like doing on Windows.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!