Testing for failing disk controller?

  • Hi All,

    I have a 10x4TB SnapRAID config with the 8 x data drives in a single unionFS coming off an IBM ServeRAID M1015 controller in "IT Mode" and 2 x drives connected via USB 3.1 as parity. This has been working well for me for sometime and transfer rates have always managed to saturate my 1Gbps network.

    Last week I started having issues with file systems being intermittently unavailable which was followed by all my devices attached via my M1015 dropping out. Seemed a little suspect to me so I shut down my NAS fully for around an hour and then booted it back up. Everything seems to be functioning, however I have noticed now that transfer speeds are massively decreased (locked at 3.5MiB/s) and it doesn't seem to matter what protocol I am using (have tried SMB, FTP and SFTP).

    My M1015 is several years old now and am wondering if it is on the way out. Are there any tools I can use to probe/test hardware or specific log entries I should be looking at that might give me some insight. Good news is these controllers are still plentiful and cheap, bad news is I have completely forgotten how I managed to flash the firmware. Anyway, first things first I guess.

  • Absolutely. I have SMART monitoring my disks. Not sure it can be used to probe the disk controller itself though. Found an Ebay seller selling M1015 units new for around $50, so just ordered myself one. Once I get it, at least I will have the parts to start swapping things around to see what makes a difference. The throughput is really starting to irritate me.

  • Just wanted to loop back on this in case it helps someone else. Ended up getting a brand new 9211-8i controller off ebay for $35USD and then used using a standard Freedos USB stick made using Rufus I added the following files based off various guides I read;

    With all this on a USB stick in the back of my NAS along with the new 9211-8i controller in place with all disks disconnected I booted into the BIOS for my motherboard and selected the option to boot into the UEFI Shell. Once loaded into this command line shell I typed (minus what is in brackets);

    • mount fs0: (to mount the USB as a file system, the file system number might be different for you so you may need to cycle through)
    • fs0: (change to USB)
    • dir (verify that USB contents are readable)

    Following commands interfaces with your disk controller and can potentially brick it. By continuing you acknowledge all risk in doing so sits on you.

    • sas2flash.efi -listall (verify your 9211-8i controller can be seen)
    • sas2flash.efi -o -e 6 (wipes the 9211-8i BIOS, do NOT reboot once this has been completed)
    • sas2flash.efi -o -f 2118it.bin -b mptsas2.rom (writes the latest P20 IT Mode firmware to the 9211-8i controller, swap out the 2118it.bin for 2118ir.bin in the command line argument for IR Mode. I don't want any RAID functionality at the controller level here, so I went with IT Mode so there is nothing getting in between OMV and the SATA disks)

    After this I just put my OMV NAS back together and everything just worked. I have been thrashing the SAMBA file transfers and very happy to say that I am once again pretty much saturating my 1gbps network, so at this stage it is looking like it was a fading disk controller that was causing the disk drop outs and massively slowed file transfer speeds.

    Hope this helps someone.

  • Nicoloks

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!