Missing disk in RAID10 array

  • Hi,


    I'm on OMV Arrakis 4.1.27.

    One of my raid is now clean,degraded.

    It was a raid10 array with 4 disk, but one of the disk has dissapeared from the array and now there's only 3 active disk.

    The missing disk is still there and up as I can create a filesystem on it.


    How can I put It back in the array ?


    Thanks in advance for any help !!


    Chrisbati



    Version : 1.2

    Creation Time : Mon Apr 29 19:16:00 2019

    Raid Level : raid10

    Array Size : 3906766848 (3725.78 GiB 4000.53 GB)

    Used Dev Size : 1953383424 (1862.89 GiB 2000.26 GB)

    Raid Devices : 4

    Total Devices : 3

    Persistence : Superblock is persistent


    Intent Bitmap : Internal


    Update Time : Fri Sep 11 16:01:19 2020

    State : clean, degraded

    Active Devices : 3

    Working Devices : 3

    Failed Devices : 0

    Spare Devices : 0


    Layout : near=2

    Chunk Size : 512K


    Name : loulous:LoulousRaid10 (local to host loulous)

    UUID : 09baaac7:e9380377:b31e2a3c:1c7620a7

    Events : 32469


    Number Major Minor RaidDevice State

    0 8 112 0 active sync set-A /dev/sdh

    - 0 0 1 removed

    2 8 48 2 active sync set-A /dev/sdd

    3 8 32 3 active sync set-B /dev/sdc

  • Wipe the drive and re add it to the array;


    Storage -> Disks -> select the drive that's dropped out (make sure it's the correct one) click wipe on the menu select short


    Raid Management -> select the degraded array, on the menu click recover, from the dialog select the drive you've just wiped click OK and the raid should resync.

  • chrisbati

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!