[Solved] Two docker containers (Tvheadend and Oscam) lose socket connection on daily basis

  • I use OMV as file and media server. I've been running a Tvheadend container (host mode) and an Oscam container (bridge mode) for several months without problems. Oscam is listening to TVH requests on port 9000. The setup used to work without problems for several months. Some weeks ago, I started to run into issues. At apparently random times (usually once or twice per day), the Oscam container would lose its "connection" to the TVH container and start writing "unknown socket" errors in it's log file. At that stage I also lost my ability to descramble programs via Oscam. Restarting either Tvheadend or Oscam (no matter which) solved the problem and reestablished the proper configuration.


    In order to "debug" the problem, I compared the timestamps of when Oscam starts writing the "unknown socket" errors, with the OMV syslog, and found smbd error messages appeared coincidently. Here the output of systemctl status smbd, which describes the errors (the last two lines also appear in the syslog):

    192.168.1.1 is the IP address of my gateway. Do you have any idea, what "breaks" the connection of the two docker containers? I'm wondering whether the smbd error is causal or just coincident with that breakage, but also don't know how to "debug" this further...


    Any help appreciated...

  • The problem reoccurs every day at roughly the same time at 12:26/12:27. I've increased the samba log level, hoping to capture more detail on the root cause. You'll find it here (too long to post inline): https://pastebin.com/hbQpys2M

    The connection between the containers broke at exactly 12:27:49 today. The log excerpt covers that time stamp, plus previous and subsequent events.


    I'd really, really appreciate any insights in what keeps causing this or on how to debug this further...

  • Solved in the meantime: The problem was caused by Ourosboros running automatic updates on docker.sock, most likely in connection with relatively recent docker upgrades. In any case, once I deactivated Ourosboros all problems were gone...

  • m4tt0

    Added the Label resolved
  • m4tt0

    Changed the title of the thread from “Two docker containers (Tvheadend and Oscam) lose socket connection on daily basis” to “[Solved] Two docker containers (Tvheadend and Oscam) lose socket connection on daily basis”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!