Error after upgrade to 0.5.29

  • Hello
    I got this error trying to update my omv.


    Code
    Fel #4000: exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get update 2>&1': Ign file: Release.gpg Ign file:/var/cache/openmediavault/archives/ Translation-en Ign file: Release Ign http://shell.ninthgate.se squeeze Release.gpg Ign http://shell.ninthgate.se/debian/ squeeze/main Translation-en Get:1 http://shell.ninthgate.se squeeze Release.gpg [490 B] Ign http://shell.ninthgate.se/packages/debian/ squeeze/main Translation-en Hit http://ftp.sunet.se squeeze Release.gpg Ign http://shell.ninthgate.se squeeze Release Ign http://ftp.sunet.se/pub/Linux/distributions/debian/ squeeze/main Translation-en Hit http://ftp.sunet.se squeeze-updates Release.gpg Hit http://ftp.sunet.se squeeze Release Hit http://security.debian.org squeeze/updates Release.gpg Ign http://security.debian.org/ squeeze/updates/main Translation-en Ign http://security.debian.org/ squeeze/updates/non-free Translation-en Hit http://packages.openmediavault.org sardaukar Release.gpg Ign http://packages.openmediavault.org/public/ sardaukar/main Translation-en Get:2 http://shell.ninthgate.se squeeze Release [2250 B] Hit http://ftp.sunet.se squeeze-updates Release Err http://shell.ninthgate.se squeeze/main amd64 Packages 404 Not Found Hit http://packages.openmediavault.org sardaukar Release Hit http://security.debian.org squeeze/updates Release Ign http://shell.ninthgate.se squeeze Release Hit http://ftp.sunet.se squeeze/main Sources Ign http://shell.ninthgate.se squeeze/main amd64 Packages/DiffIndex Hit http://shell.ninthgate.se squeeze/main amd64 Packages Hit http://ftp.sunet.se squeeze/main amd64 Packages Hit http://ftp.sunet.se squeeze-updates/main Sources/DiffIndex Hit http://ftp.sunet.se squeeze-updates/non-free Sources Hit http://packages.openmediavault.org sardaukar/main amd64 Packages Hit http://security.debian.org squeeze/updates/main Sources Hit http://security.debian.org squeeze/updates/non-free Sources Hit http://security.debian.org squeeze/updates/main amd64 Packages Hit http://security.debian.org squeeze/updates/non-free amd64 Packages Fetched 491 B in 0s (746 B/s) W: GPG error: http://shell.ninthgate.se squeeze Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E639BFCB72740199 W: Failed to fetch http://shell.ninthgate.se/debian/dists/squeeze/main/binary-amd64/Packages.gz 404 Not Found E: Some index files failed to download, they have been ignored, or old ones used instead.' in /usr/share/openmediavault/engined/rpc/apt.inc:331 Stack trace: #0 [internal function]: OMVRpcServiceApt->update(NULL, Array)


    please help, I'm really new at this

  • Wait, I write something different. It looks like you don't have keyring installed. Do this:


    apt-get install curl

    Code
    echo "deb http://shell.ninthgate.se/packages/debian squeeze main" >> /etc/apt/sources.list
    curl http://shell.ninthgate.se/packages/shell-ninthgate-se-keyring.key | sudo apt-key add -


    That is all one line for command line. Selet all copy and paste it in putty.
    Then try apt-get update. See if your error is gone. Curl is probably installed. I do this just to make sure this long command will run correctly.

  • If you installed omv-extras and enabled the plex repo, it would do both of those commands for you :)

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I thought as much.


    Code
    Packages Fetched 491 B in 0s (746 B/s) W: GPG error: http://shell.ninthgate.se squeeze Release: The following signatures couldn't be verified because the public key is not available:
  • The plugin doesn't download it. The key file is included with the plugin.

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Must be although I didn't get an error when I just did an apt-get update on my machine...

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Even if I made omv-extras a dependency of the plugin, it still wouldn't enable the repo (although the key would be installed). Not sure how to fix/stop this problem.

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!