Error after upgrade to 0.5.29

  • After the upgrade to 0.5.29 I have two problems.


    - The transmission plugin doesn't work anymore.
    But transmission is accesible through ip:9091
    - I get the following error
    Failed to execute command 'export LANG=C; apt-get update 2>&1': Ign file: Release.gpg Ign file:/var/cache/openmediavault/archives/ Translation-en Ign file: Release Hit http://www.deb-multimedia.org squeeze Release.gpg Ign http://www.deb-multimedia.org/ squeeze/main Translation-en Ign http://www.deb-multimedia.org/ squeeze/non-free Translation-en Hit http://ftp.be.debian.org squeeze Release.gpg Ign http://ftp.be.debian.org/debian/ squeeze/main Translation-en Get:1 http://ftp.be.debian.org squeeze-updates Release.gpg [836 B] Ign http://dh2k.omv-extras.org sardaukar-miller Release.gpg Ign http://dh2k.omv-extras.org/debian/ sardaukar-miller/main Translation-en Ign http://ftp.be.debian.org/debian/ squeeze-updates/main Translation-en Ign http://ftp.be.debian.org/debian/ squeeze-updates/non-free Translation-en Hit http://security.debian.org squeeze/updates Release.gpg Ign http://security.debian.org/ squeeze/updates/main Translation-en Hit http://www.deb-multimedia.org squeeze Release Hit http://packages.openmediavault.org sardaukar Release.gpg Ign http://packages.openmediavault.org/public/ sardaukar/main Translation-en Ign http://security.debian.org/ squeeze/updates/non-free Translation-en Hit http://ftp.be.debian.org squeeze Release Hit http://dh2k.omv-extras.org sardaukar-miller Release Hit http://packages.openmediavault.org sardaukar Release Get:2 http://ftp.be.debian.org squeeze-updates Release [113 kB] Hit http://security.debian.org squeeze/updates Release Ign http://dh2k.omv-extras.org sardaukar-miller/main amd64

  • You didn't get all of the error message. Can you post it again and put it in a code box?


    I'm actually getting an error as well. It is about openmediavault-downloader and I have it installed!


    Code
    Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-downloader 2>&1': E : Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E : Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I got the same error on three systems. I need to try on a fresh VM with no plugins installed. None of these systems got the error before 0.5.29... They all complain about openmediavault-downloader and two have it installed.


    I get the same error on a fresh VM with no traces of omv-extras. If you wait, you still get the list of plugins after the error. Something changed in 0.5.29...

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Change log for 5.29:


    * Update locales.
    * Refactor JS overrides to prevent ECMAScript6 compatibility problems.
    * Mantis 0000936: Plugin-Section - Sortable Collums: sorting is not working
    across more than one side.
    * Mantis 0000940: Incorrect spelling.

  • Nope, it is not working


    TorrentList.js file


    Took commas off lines 110 and 154 causing errors. Still not displaying.


    It is something in the Configure Tab or configure folder. When I change name to Configure with no .js the manage stuff is displaying.

  • I now get the following error and I have not installed autoshutdown


  • The error has nothing to do with autoshutdown either. Reboot your system and this error is gone.


    Greetings
    Fabid

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • "Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?" Just says it all... Either you're a geek like us and have apt open in another shell or when using OMV it got stuck from the gui. So a reboot is the simpliest solution I think.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • That is same problem on my vm.


    It does a simulate reinstall on the packages before it renders them to the plugin section TAB. It seems to be waiting to long before the next simulate reinstall wants to run and is getting hung up. So any package could list this error, wherever it gets stuck in the list. May only be issue on slow machines or with people that have slow internet. If you click on "ok" to get out of the error message and then click on "check" above you should still be able to get list of plugins in the mean time. My vm is probably slow and it is why I'm having this issue. But the increase in the number of plugins is likely a contributor to it as well.

  • I also have the same problem, in the left panel, the BitTorrent button does nothing.
    When I enter the plugins button gives me the following error:


    Is there a solution?
    thanks

  • The error in your code box is an annoyance for now. Volker is working on the fix.


    Transmission should be fixed with newest version.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Volker created a workaround that I imagine will be in 0.5.30. Otherwise, it is just an annoyance. It doesn't affect anything. The list of plugins will still show up.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yep. See:


    http://sourceforge.net/p/openm…d1a2b5fcbc911f759d51d:837


    The fix will be in 0.5.30.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Underlying bug will be resolved in Ext4JS version 4.2.3.


    http://www.sencha.com/forum/showthread.php?264958


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!