Nextcloud - Letsencrypt issue

  • when I go to my_URL/nextcloud I get this error on a web page:

    Code
    Internal Server Error
    The server encountered an internal error and was unable to complete your request.
    Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
    More details can be found in the webserver log.
  • IT WORKED! I am getting to the Nextcloud initiation page.

    Thank you so much.


    Maybe worth updating the original instructions as the file size error always appears until I change to 1024m as you mentioned in your earlier post above.

  • no i am getting the following error on the initial Nextcloud setup page:


    Error

    Error while trying to create admin user: Failed to connect to the database: An exception occurred in driver: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Try again

  • The error message suggest that nextcloud can't connect to the database.

    I also had this issue some time ago. Not sure if its the same problem. It was after an update of the mariaDB image, that prevented nextcloud from creating the database.

    The solution was to bring up the database yourself. The "easiest" way to do this:

    Stop your containers: docker-compose down

    Remove the mariaDB config folder: e.g. rm -r /srv/dev-disk-by-label-disk1/appdata/nextclouddb

    Edit your docker-compose.yml: nano docker-compose.yml

    Edit the section of mariadb to look like this:

    Save the file: CTRL +x ; y; ENTER

    Bring the containers up again: docker-compose up -d

    When at the nextcloud setup page enter these credentials:

    • Database user = nextcloud
    • Database password = somepassword
    • Database name = nextcloud
    • Database location = nextclouddb
  • Post by MarcS ().

    This post was deleted by the author themselves: e ().
  • The swag container is complaining now and not generating any more certificates. Do you know any workarounds here?:


    Code
    There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains: cayu2020n.xyz: see https://letsencrypt.org/docs/rate-limits/
  • Some people are reporting that this error has something to do with localhost settings. Do you know where I would need to change these?


    SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

    'm here because I update my php version from php 5 to php56. If you have admin right you can log into root and look for /etc/hosts. This file controls the location of localhost. I opened settings.inc.php and changed this define('_DB_SERVER_', 'localhost:3306'); to reference define('_DB_SERVER_', '127.0.0.1'); and now my website works!

  • Is there a way to log into the container and do some tests on the database?

    docker exec -it nextclouddb bash gives a bash console inside the mariadb container



    SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

    'm here because I update my php version from php 5 to php56. If you have admin right you can log into root and look for /etc/hosts. This file controls the location of localhost. I opened settings.inc.php and changed this define('_DB_SERVER_', 'localhost:3306'); to reference define('_DB_SERVER_', '127.0.0.1'); and now my website works!

    I highly doubt that going that route will help you. Because we do not use localhost as our database path. We use the container name because the docker internal dns service will resolve it to the address.


    But unfortunately I dont have any more ideas to troubleshoot this. Have you checked the log of the mariadb container? Any issues there?

  • I checked mariadb log. Do you see anything?



    [s6-init] making user provided files available at /var/run/s6/etc...exited 0.,

    [s6-init] ensuring user provided files have correct perms...exited 0.,

    [fix-attrs.d] applying ownership & permissions fixes...,

    [fix-attrs.d] done.,

    [cont-init.d] executing container initialization scripts...,

    [cont-init.d] 01-envfile: executing... ,

    [cont-init.d] 01-envfile: exited 0.,

    [cont-init.d] 10-adduser: executing... ,

    ,

    -------------------------------------,

    _ (),

    | | ___ _ __,

    | | / __| | | / \ ,

    | | \__ \ | | | () |,

    |_| |___/ |_| \__/,

    ,

    ,

    Brought to you by linuxserver.io,

    -------------------------------------,

    ,

    To support LSIO projects visit:,

    https://www.linuxserver.io/donate/,

    -------------------------------------,

    GID/UID,

    -------------------------------------,

    ,

    User uid: 1004,

    User gid: 1004,

    -------------------------------------,

    ,

    [cont-init.d] 10-adduser: exited 0.,

    [cont-init.d] 30-config: executing... ,

    [cont-init.d] 30-config: exited 0.,

    [cont-init.d] 40-initialise-db: executing... ,

    [cont-init.d] 40-initialise-db: exited 0.,

    [cont-init.d] 99-custom-scripts: executing... ,

    [custom-init] no custom files found exiting...,

    [cont-init.d] 99-custom-scripts: exited 0.,

    [cont-init.d] done.,

    [services.d] starting services,

    [services.d] done.,

    201122 14:04:47 mysqld_safe Logging to syslog.,

    201122 14:04:47 mysqld_safe Starting mysqld daemon with databases from /config/databases

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!