Hair pulling 😖🤯 Frustrating --> Raspberry Pi --> OpenMediaVault -->WiFi (WiFi stops working)

  • * My asterisk clause quote. --> I'm well versed in computers (I've been teaching computer/programming for decades)


    There are very few problems that I can't figure out when it comes to computers. Usually, it's something extremely simple, which I'm making it more complicated than it is. I've taught myself to walk away, take a shower, walk the pups, get a good night sleep, and then I can usually figure it out. Most the time it's something extremely simple.

    I have been racking my brain 🤯🤯 for two weeks on this. I can't figure it out, so I need some help from the community to help me solve this problem.


    I have a Raspberry Pi 4 8gb of memory as my Plex media server (using docker), and NAS for family file server. It's on WiFi, sits over in the corner of the house and works flawlessly. No problems at all. Love the little thing.


    I have another Raspberry Pi 4, 2gb of memory. My procedure that I have done:


    1. Flashed Raspberry Lite on to the 32gb micro sd card (I've tried two different SD cards)

    2. sudo raspi-config (Turned on SSH, configured WiFI, and change hostname to omv-bckup

    (Unplugged the cat-5 cable and SSH in from my desktop Mac)

    3. sudo apt-get update | sudo apt-get upgrade
    4. reboot

    5. sudo wget -O - https://raw.githubusercontent.…tallScript/master/install | sudo bash

    6. After install rebooted the machine

    (Things I have tried, skip the sudo raspi-config on setting up the WiFi in the beginning. Install OMV then add the WiFi device in OMV. But that doesn't work. And going back into raspi-config works but when I reboot it resets the WiFi config. In /etc/wpa_supplicant/wpa_supplicant.conf is empty except that first starter line. So I have to re-install OMV.)

    7. I setup the NTP to Mountain time, upgrade the plugins (only one needs upgraded), install the Luks Encryption plugin as my hard drive is encrypted using Luks plugin.

    After about two hours I can't access OMV by WiFi. I'm using an old 5TB seagate (When I say old it's three years old lol but...in technology world I guess it's old)USB3.0 hard drive. So, I tried a new hard drive. (Just FYI. the hard drive has it's own power cable, the Rasp is not powering the hard drive).

    The only way I can access the OMV is either: Plugin the cat-5 cable in again (I have access again) or reboot the Rasp.


    Since I already have one OMV up and running on the Rasp using WiFi with (with basically the same procedures that I did on this one) no problems I figured maybe I just have a bad Rasp.

    I repeated all these procedures with a new microSD card on a new Rasp 4 with 8GB this time. Just like my main OMV server. Save thing is happening. WiFi stops working after about 2 hours.


    I check the logs and I can't find anything out of the ordinary. I'm pulling my hair out at this point 😖😣😣. I'm so frustrated...and as I teach my kids in life and especially in programming...KISS. Keep it simple stupid. I'm sure it's something simple that I'm missing.


    Any help would be greatly appreciated!


    Thank you,

    David

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

    Edited 2 times, last by wildernessfamily: Spelling error ().

  • macom

    I'm confused. Am I missing a step on updating Raspian OS?

    1. Flashed Raspberry Lite on to the 32gb micro sd card

    2. sudo raspi-config (Turned on SSH, configured WiFI, and change hostname to omv-bckup

    (Unplugged the cat-5 cable and SSH in from my desktop Mac)

    3. sudo apt-get update | sudo apt-get upgrade

    4. reboot

    5. sudo wget -O - https://raw.githubusercontent.…tallScript/master/install | sudo bash


    If I don't do raspi-config on step 2 it dosn't save my WiFi settings after step 5. I have to re-install.

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • macom

    Macom, first thanks for taking the time to help.


    I actually have tried that twice. I skipped the step 2. Installed OMV.

    1. Logged into OMV. Network --> Interfaces

    eth0 is added but no wifi (of course since I havn't set it up yet)

    I click add --> wifi.

    I add wlan0. Set the SSID and password. I setup IP4 and IP6 to DHCP. And Save

    No wifi connection. I reboot.

    Still no wifi connection.

    I run sudo raspi-config setup wifi in raspi-config

    And then run ifconfig and confirm I have a IP address. All is good.

    But, when I reboot, I loose wifi and have to repeat the raspi-config procedure again.

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • macom

    No, I was unaware of `omv-firstaid`. I just read the doc on it.

    That might be the trick! I will try that out in a few hours.

    Thank you for that.


    Just to make sure I have it correct.

    1. Flash RaspOS on sd card.

    2. sudo apt-get update | sudo apt-get upgrade

    3. reboot

    4. Install OMV

    5. Run omv-firstaid

    Correct?

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • Flash card

    install omv with script

    then do whatever you want. If you setup wpa_supplicant.conf according to this guidebefore running the script, wifi should work too.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron

    Thanks for responding.

    I tried that. I flashed the sd card. Did the normal sudo update, upgrade, reboot, and then install OMV with the script.

    Then I did the raspi-config the first time. And when I reboot it looses the config and wlan0 dosn't obtain ip. I cat the wpa_supplicant file and it's empty other than the basic first line that ships with the Rasp. Then (which I prefer anyway) I edited wpa_supplicant.conf with nano per that guide. On my other OMV server I actually use this guide Rasp WIFI guide and encrypt the PSK key with wpa_passphrase but I haven't even attempted that on this OMV server until I can fix this WiFi problem I'm facing.


    I just ran sudo omv-firstaid and it said it configured the wifi. I'm not setting my hopes to hi but before I flash the sd card again I figure why not try.


    If it dosn't work than I'm going to try:
    1. Flash SD
    2. apt update upgrade
    3. reboot
    5. OMV install script
    6. omv-firstaid
    and 🤞🤞🤞that will solve the wifi problem. What is so baffling is that I have the other OMV on Rasp working with no problem and I havn't done anything different. It's driving me nuts trying to figure out what I'm doing wrong.
    I'll post my results on what happens.

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • You are still doing too much. In order to make my testing not have to support infinite possibilities, you should only write the image to the sd card and boot it. Don't update. This can introduce lots of changes. Then only write the wpa_supplicant.conf file by hand. Do not raspi-config. This is the only way my script will support wifi (I never wanted to support wifi in the first place). I have tested this method over a hundred times and have never had a wireless issue. After you have omv working, update/upgrade/do whatever you want. But save all of that until after the script has been run.

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron


    Ahh, gotcha ya! Totally understandable.

    I'm just going to do.

    1. Flash SD

    2. Update the wpa_supplicant.conf with nano

    3. run OMV script.


    I'm sure it's something that I'm doing not your script. Most likely what you said. I'm proceeding with the wrong order of things.

    Thanks for an awesome script.

    And, thanks for WiFi! I live up in the mountain of Colorado and don't have internet. Just the mobile hotspot...waiting anxiously for StarLink to come online. I can't backup my files to the cloud because all I have is the hotspot. I purchased a weatherproof box and installing it in an unattached ground cellar. Just in case god forbid a fire or wildfire happens.

    I try to support OpenSource projects. I'l be doing that with OMV. It's great and extremely beneficial for my situation up here in the mountains. Again, great job and thank you!

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • I have no idea what is going on. I have been working on this problem every day for a week.

    These are the steps I have done.


    Background: I tried on a Pi3B+, Pi4,2gb, and Pi4,8gb

    I'm on a Mac. I downloaded the Raspberry Pi Imager that I have used for....over year...+


    I placed my MicroSD card into the slot. Choose Erase, then choose Raspberry Pi OS (Other)-->Raspberry Pi OS Lite (32bit). I flash the sd card and all goes well.


    I place it in the Raspberry Pi and boot it up. I have no USB drives connected. Only my monitor, and USB keyboard and no cat5.


    Code
    I first edit the keyboard file so I can use my keyboard.
    sudo nano /etc/default/keyboard

    I change

    Code
    XKBLAYOUT from gb to us


    I then edit the wpa_supplicant.conf file adding under the last line update_config=1


    Code
    country=us
    network {
    ssid="OMV-Test"
    psk="pasword123"
    }

    Note: Yes, I created a SSID on my router called OMV-Test so I could watch it and keep it away from any other traffic.


    I then run

    Code
    wpa_cli -i wlan0 reconfigure

    I receive an "OK" back

    At this point per the Raspberry Pi instruction WiFi should be working. What they don't tell you is since a recent update you have to unblock/turn on your WiFi radio by running this command then rebooting.

    Code
    sudo rfkill unblock all
    sudo reboot


    Once the machine reboots and I perform an

    Code
    ifconfig wlan0

    I have an ip address and I confirm this with my router.


    Note: I DO NOT run apt update | apt upgrade at all. At anytime.


    I then run the command:

    Quote


    OpenMediaVault installer runs and installs. The system reboots per the install script.

    When it reboots and I login and run ifconfig wlan0 there is no ipaddress. I confirm with the router.


    I then do a sudo cat /etc/wpa_supplicant/wpa_supplicant.conf and my text that I added is still there.

    I try running wpa_cli -i wlan0 reconfigure again. I receive an OK.

    No ip address

    I try sudo rfkill unblock all

    reboot

    No ip address

    I plug the cat5 cable in and receive an ipaddress.


    I log-in to OpenMediaVault, proceed to Network-->interfaces. My information is in there that I had initially added to wpa_supplicant.conf

    I change network in OpenMediaVault to OMV-Test-2 --> Password --> Save

    It then asks if I want to apply the changes. I say yes.

    I'm connected to my network. I unplug the cat5

    I go back and do the procedure again in OpenMediaVault back to the original network SSID: OMV-Test, apply the changes and I'm connected.

    I reboot the machine and no connection

    I log-in do a ifconfig wlan0 and confirm no ipaddress

    It looses something when I reboot.


    At the command line I edit:

    Code
    sudo nano /etc/network/interfaces

    I add the line:

    Code
    iface wlan0 inet dhcp

    save and exit

    Code
    sudo ifup wlan0

    After running that I have an ip address. I'm connected to the router.

    I reboot the machine. Again, all is loss.

    I go back to /etc/network/interfaces and my text that I had added is gone.

    There is no iface wlan0 inet dhcp in the interface file.


    Like I said, I have tried this several times, on several Pis, several SD cards, several flashes. I've tried being connected entirely with cat5 and not even editing the wpa_supplicant.conf file at all.


    I have no idea what I'm doing wrong or what the problem is.


    ryecoaaron is there anything you can recommend? I don't know what else to try.

    Thank you for any assistance!

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • is there anything you can recommend? I don't know what else to try.

    There are many things wrong. I really hate trying to support wifi.... If you are going to setup wifi and not use ethernet to install then you need to skip the network setup that the script does. And if you ever want to use OMV networking, you will need to use netplan (not /etc/network/interfaces).


    To skip networking (this is documented on the readme for the script - https://github.com/OpenMediaVa…-Developers/installScript)

    wget https://github.com/OpenMediaVault-Plugin-Developers/installScript/raw/master/install

    chmod +x install

    sudo ./install -n


    If you can use ethernet to run the script, ONLY do the following:


    write image to SD card

    Boot RPI

    Write wpa_supplicant.conf file but nothing else. no wpa_cli commands or rfkill or anything

    Run script

    Configure networking from web interface

    omv 5.5.12 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi ryecoaaron ,

    First, let me just say, I do appreciate the time you take to respond. It's greatly appreciated.


    Before, I responded I wanted to verify because I had tried this several weeks ago. I did want to try again just to verify using just ethernet.


    Side note: I prefer to install over ethernet. In fact, if possible I would like to keep it on Ethernet and not deal with WiFi. But, this is the back-up sever in case of a wildfire and I don't have the means to run a cable to where it will be located.


    I erased three SD cards. Flash Raspberry OS Lite on them. (Rasp 3B+, Rasp4,2gb, Rasp4, 8gb)
    I have the HDMI-Mini, USB Keyboard, and Cat5 plugged in.

    Turned all three Rasps on and booted up.
    I did edit the keyboard file so I could use my keyboard on all three rasps
    sudo nano /etc/default/keyboard
    and change gb to us


    On two of the Rasps (3B+ 4,8GB)

    I typed in the install script:
    wget -O - https://github.com/OpenMediaVa…Script/raw/master/install | sudo bash

    On the Rasp 4,2gb I did
    sudo rfkill unblock all
    reboot

    and then the install script.

    I read in another post that your script does the rfkill unblock. I read that after I already done it. But. either way I have the other two rasps running as normal.

    All three installed with no problems.

    I logged into terminal and did a ifconfig

    eth0 is showing with an ip address assigned but not wlan0 (which is correct)


    I logged into the web UI. Network-->Interfaces-->Add Wifi The wifi interface was available in the drop down.

    I added the network and password. For both IP4 and IP6 set to DHCP.

    Applied the changes

    No ip address

    I logged into terminal, performed ifconfig

    eth0 is still there and wlan0 is now showing with the mac address but no IP.

    I rebooted.

    Again, wlan0 is showing but no ip address


    The only thing I can think of is that when I setup a Raspberry Pi for other projects and turn on wifi I have to perform the rfkill unblock which your script does.

    But...if I don't assign a country for the wifi

    country=us

    wlan0 does show up with the mac address when I perform a ifconfig but will not allow it to hit the dhcp server until I assign the country in the wpa_supplicant.conf file.


    Does the script set a country for the wifi adapter?


    That is the only thing I can think of.


    I'll keep trying if you have suggestions for me to try. But, I can't think of anything else at point.


    Again, I appreciate any feedback and your time.

    David

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • Give this -> R-PI guide a try. Please go through it step by step. It has been well tested on the R-PI4 and I know of at least one instance were it worked with a 3B. Note that setting up wifi is at the very end of the process. Thousands have been using it and there have been no wifi complaints in a very long time.


    For burning the image and testing the SD-card, I'll assume you have Mac equivalents for the Windows app's referenced.

    As a note, this guide does not use a keyboard, monitor, a mouse, etc., so don't connect them. Peripherals shouldn't matter on an R-PI4 but they may have an impact on an R-PI 3B if the power supply is marginal and / or the USB cable connecting the PS to the R-PI is too long with thin gauge wire.

  • Thanks for responding crashtest

    That's actually the guide I've been going off of :) But it's a little conflicting from what ryecoaaron has said. To flash rasp. Do not apt update / upgrade first. Install OpenMediaVault first than do the update/upgrade.

    The only thing I strayed from on regards to the guide was using this version of Raspberry Lite that it states.

    1. Buster Lite was:9e5cf24ce483bb96e7736ea75ca422e3560e7b455eee63dd28f66fa1825db70e

    I couldn't find it. I looked through all the repositories and I wasn't able to find it.

    I'm using the official MacOS Imager from the Raspberry Pi website raspberrpi.org
    https://downloads.raspberrypi.org/imager/imager_1.4.dmg

    To create my images. When I choose "Other" from the imager --> Raspberry Lite 32bit version is the version I'm using.


    I don't see what I'm doing different than anyone else. Plus, like I said in my first post. I have the very same setup using a Rasp 4 8gb with OpenMediaVault working like a charm. I have docker setup, with Plex. And, it's doing fantastic. I used the same script. Same procedures. In fact, I used your guide and did the apt update / upgrade first prior to installing OpenMediaVault with no problems. After setting this up and about 4 to 8 weeks later I decided that this was perfect to use for my so called backup server.


    That's when I ordered a Raspberry Pi 3B (for a weather station I'm building), 4GB 2GB (for my backup server), 4gb 8GB (to develop some python scripts for a few Rasp projects), and another Rasp 4 8gb for the backup server.


    🤔The only variables that I can see that are different than the first setup of OpenMediaVault is:

    1. I have a new router. I have a high end Asus router that I flash OpenWRT with a private ALGO VPN / WireGuard setup on it. (But, it's running my other OpenMediaVault, I have NUMEROUS LoT devices attached to it running the house, and all my other computer equipment (MacBook Pro, iPad, Phones, etc.) with no problem.

    2. I purchased these three new Raspberry Pi from PiShop.us (an official vendor of Raspberry Pi). The first Rasp that has OpenMediaVault running with Plex from VilROS (another official vendor of Raspberry Pi) on Amazon. They come from Raspberry Pi, they were in the official box. I don't see how that could be it either.


    At this point I throwing in the towel. I don't know what else I can do. Last night I flash Raspberry Pi Light. Using the command line I encrypted the drives with Luks. I have it all installed outside. And RSync is running as we speaking backup everything with no problems. It would have been nice to have OpenMediaVault on it for the U.I. but...being just a backup server and only needing Rsync, Luks, and S.M.A.R.T I probably should have just done it this way from the beginning.


    All that said...I want to thank ryecoaaron and crashtest for your input and your time. I do appreciate it!

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • OK, I rebuilt using the current image - 2020-08-20-raspios-buster-armhf-lite - using the method in the guide.

    The only thing I did that is not specifically called out in the guide; I set a static address on eth0 before configuring wifi.
    Wireless (wlan0) is DHCP, per the guide.

    At this moment, eth0 is disconnected. I'm connected to the R-PI4 wireless only.


    pi@R-PI4:~ $ ip add

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000

    link/ether dc:a6:32:57:17:77 brd ff:ff:ff:ff:ff:ff

    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether dc:a6:32:57:17:79 brd ff:ff:ff:ff:ff:ff

    inet 192.168.1.67/24 brd 192.168.1.255 scope global dynamic wlan0

    valid_lft 258838sec preferred_lft 258838sec

    pi@R-PI4:~ $



    ________________________________________________________________________


    So, what could the issue be?

    From a network perspective, note that "running" OMV is far different from "building" OMV. I noticed that you had a successful OMV build before you installed your new router. Along those lines and to speculate, the Asus router may have firewall settings that are preventing you from downloading from a specific source or, perhaps, it's limiting certain types of downloads, a specific type of network connection, etc.

    As a test, you might try setting aside the SD-card with the working OMV software build, and build another SD-card on the same (known working) R-PI, in the network environment setup by your new router.
    As a second test, you might try building OMV with your old router installed to see what happens. The entire build can be done is less than hour so the inconvenience shouldn't too great.

  • Hi, crashtest

    I figured it has to be me. I can't be the only person building Rasp with OMV on it at this present moment. It's to popular.


    Flashing and building OMV is snap of the fingers to me. I have a 4K TV that i use as my monitor. I have my Mac plugged into one of the HDMI ports and then when I build Raps it connected to the other HDMI port. I just switch between input's while the script does it's thing.


    I don't the other router, I gave it away. But, I'll turn on my phone's hotspot. And completely do it through my hotspot.


    Thank you for showing a screen shot of your OMV WIFI. My initial OMV that is working may not be setup correctly. In the WIFI settings are (see screen shot) it does not display any wifi settings. Or when connected to ethernet it does not show that either. hmmm.

  • Again, when I build, I have no peripherals connected to the R-PI (Important for R-PI's 3 and below, not so important for the R-PI4). HDMI connections consume power.

    A notable difference is, I have IPV6 disabled. (I have no idea if there's any effect.)

    Also, since you have more than 1 SD-card, I would try setting aside my working SD-card and building OMV on another SD-card, using the known working R-PI. There's nothing to lose by running that test.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!