[SOLVED] Hair pulling 😖🤯 Frustrating --> Raspberry Pi --> OpenMediaVault -->WiFi (WiFi stops working)

  • SOLVED!!!

    I can't believe the amount of time I have put into this. Maybe this is why I became a developer. Sometimes I think I should have been a detective. When there is a mystery I can't let it go. I have to find the answer. The countless hours that I have put into this. I don't even want to think about the number of times I have flash OMV, the number of SD cards I have tried, resetting my router multiple times, changing DNS servers, trying just IPV4 or IPV6. But, I finally remembered how I did it the very first time. And that was the answer to solving this problem.


    To recap. No matter what I did I couldn't get OpenMediaVault to install and work with WiFi. Or it would give me errors installing. But that's all the farther I went. I would stop there and re-install...And the process would repeat.


    Yesterday was different. I've been working with Django and loving it. So much better than WordPress (legal disclaimer: in my opinion 😁). I wanted to set up OMV and use Docker/Portainer with OMV. OMV makes it super easy to use Docker. I got some 3M command hooks and was just going to stick the Rasp next to the router and use Cat5. I had trouble installing OMV. Even with CAT-5. I would receive the error while installing that some packages could not be installed. It would stop and prompt me to try running apt update --fix-missing. Sometimes that worked. Sometimes I would have to try multiple times. Reboot the Rasp. Try again. Frustrating to say the least 🤯🤬


    I would finally get Docker and Portainer installed. But, I was downloading images on Portainer and I would receive DNS errors. Which was the light bulb in my head that went off💡. I remembered that I had received DNS errors before. I did a search and I immediately found the article that I had the first time I installed OMV.


    The default mirror: http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

    was causing all the problems. I have no idea why and at this point I really don't care.


    I switched to a new mirror repository.

    http://mirrors.syringanetworks.net/raspbian/raspbian/


    And, everything works perfectly. WiFi works, Docker works, Portainer is able to download images.


    If anyone else seems to have this problem these are the steps I did to make my OMV setup work with Rasp.

    Now, depending on when your reading this you may not be on Buster (Raspberry OS version) which just happens to be the name of my dog. The yellow in my avatar. Just thought I throw that out there. You may have to change to the current version.


    Here is the list of Rasp mirrors: https://www.raspbian.org/RaspbianMirrors


    Good luck!

    🏔Salida CO UTC-6 (Mountain, outdoor, and animal lover)

    Python developer, web developer (php, MySQL, WordPress), pilot, and teacher 👨‍🏫.

    Amateur Extra, amateur radio (ham radio) - K0BCJ

    * Please excuse any spelling or grammar mistakes I was born with severe dyslexia.

  • wildernessfamily

    Changed the title of the thread from “Hair pulling 😖🤯 Frustrating --> Raspberry Pi --> OpenMediaVault -->WiFi (WiFi stops working)” to “[SOLVED] Hair pulling 😖🤯 Frustrating --> Raspberry Pi --> OpenMediaVault -->WiFi (WiFi stops working)”.
  • votdev

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!