Fehler beim Speichern von NTP-Server benutzen

  • Hallo,


    Neuinstallation von aktueller Debian Buster Netinstall mit nachträglich installiertem OMV5.


    Wenn ich den NTP-Server über die WebGui speichern will bekomme ich folgende Fehlermeldung:

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run chrony 2>&1' with exit code '1': OMV-Debian.fritz.box: ---------- ID: configure_chrony Function: file.managed Name: /etc/chrony/chrony.conf Result: True Comment: File /etc/chrony/chrony.conf is in the correct state Started: 22:35:33.935779 Duration: 32.21 ms Changes: ---------- ID: start_chrony_service Function: service.running Name: chrony Result: False Comment: Job for chrony.service failed because the control process exited with error code. See "systemctl status chrony.service" and "journalctl -xe" for details. Started: 22:35:33.976302 Duration: 57.598 ms Changes: Summary for OMV-Debian.fritz.box ------------ Succeeded: 1 Failed: 1 ------------ Total states run: 2 Total run time: 89.808 ms


    Details:



    systemctl status chrony.service


    Ansonsten läuft das System ohne Probleme.


    Gruß,

    strike

  • /etc/chrony/chrony.conf

  • Die Konfiguration sieht gut aus. Steht sonst noch etwas im syslog? Kann leider mit Google nichts finden was den Fehler Could not open any command socket betrifft.


    Kannst Du mal folgende Befehle in unterschiedlichen Terminals laufen lassen?

    • journalctl -f
    • systemctl restart chrony
  • hier die Ausgabe von journalctl -f ab dem restart von chrony


  • hier noch die Ausgabe von journalctl -f ab dem restart von chrony auf einem zweitem System. Hier ist alles IO.

    Code
    Sep 22 14:30:53 OMV5-Buster chronyd[580]: chronyd exiting
    Sep 22 14:30:53 OMV5-Buster systemd[1]: Stopping chrony, an NTP client/server...
    Sep 22 14:30:53 OMV5-Buster systemd[1]: chrony.service: Succeeded.
    Sep 22 14:30:53 OMV5-Buster systemd[1]: Stopped chrony, an NTP client/server.
    Sep 22 14:30:53 OMV5-Buster systemd[1]: Starting chrony, an NTP client/server...
    Sep 22 14:30:53 OMV5-Buster chronyd[12030]: chronyd version 3.4 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +SCFILTER +SIGND +ASYNCDNS +SECHASH +IPV6 -DEBUG)
    Sep 22 14:30:53 OMV5-Buster chronyd[12030]: Frequency -4.727 +/- 0.074 ppm read from /var/lib/chrony/chrony.drift
    Sep 22 14:30:53 OMV5-Buster chronyd[12030]: Loaded seccomp filter
    Sep 22 14:30:53 OMV5-Buster systemd[1]: Started chrony, an NTP client/server.
    Sep 22 14:30:57 OMV5-Buster chronyd[12030]: Selected source 131.188.3.220


    Das erste System habe ich mit Debian on Top installiert. Bei diesem funktioniert chrony nicht.

    uname -a

    Linux OMV-Debian.fritz.box 5.4.60-1-pve #1 SMP PVE 5.4.60-2 (Fri, 04 Sep 2020 10:24:50 +0200) x86_64 GNU/Linux


    Das zweite System habe ich mit dem ISO installiert. Bei diesem ist alles IO.

    uname -a

    Linux OMV5-Buster 5.7.0-0.bpo.2-amd64 #1 SMP Debian 5.7.10-1~bpo10+1 (2020-07-30) x86_64 GNU/Linux


    Wieso werden hier unterschiedliche Kernel verwendet?

    Wobei, das dürfte aber nichts mit dem chrony Problem haben.

  • Sytem 1 Debian onTop:

    Code
    apt list --installed | grep apparmor
    WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
    apparmor/stable,now 2.13.2-10 amd64 [Installiert,automatisch]
    libapparmor1/stable,now 2.13.2-10 amd64 [installiert]


    System 2 OMV5 vom ISO

    Code
    apt list --installed | grep apparmor
    WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
    libapparmor1/stable,now 2.13.2-10 amd64 [installiert]


    Es ist demnach auf beiden Systeme die gleiche Version von Apparmor installiert.


    Wenn ich diesem Link folge, ist demnach der Bug seit Oct. 2018 behoben.


    Debian Bug report logs - #871441


    Code
    Date: Sun, 21 Oct 2018 10:19:30 +0000
    Source: apparmor
    Source-Version: 2.13.1-1
    We believe that the bug you reported is fixed in the latest version of
    apparmor, which is due to be installed in the Debian FTP archive.
  • OMV installiert durch Abhängigkeiten nur die AppArmor Libraries, nicht aber den Service. Dass der Bug behoben ist hab ich auch gesehen, dennoch scheint mit der AppArmor Konfiguration für chrony etwas nicht zu stimmen. Mir scheint das Problem aber nur auf Dein System bezogen zu sein, da hier ansonsten öfters und schon vor langer Zeit solche Fehlermeldungen gemeldet gemeldet worden wären.

  • Quote

    Mir scheint das Problem aber nur auf Dein System bezogen zu sein, da hier ansonsten öfters und schon vor langer Zeit solche Fehlermeldungen gemeldet gemeldet worden wären.

    Genau, das denke ich auch. Sonst wären schon mehrere Fehlermeldungen in letzter Zeit gemeldet worden.


    Ich werde ggf. noch mal neu aufsetzen, Geht ja relativ flott.

    Danke noch mal.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!