Buffer I/O error, EXT4-fs error

  • Over the past few months I've gotten seemingly random disk errors on my OMV setup. A reboot fixes the problem temporarily, and this last time I've been up now for 48 days without any problems. So I haven't been able to figure out what triggers it. Normally I notice my Plex server is down and I can't log into the web interface. Then on the CLI I just see what's in the picture repeating. From what I've tried to research It's sounds like maybe the disk is going bad? But wondering if anyone else similar problems before I go buy a new hard drive? Any ideas?

  • What does SMART say? In the GUI go to Storage, SMART, in the Settings tab, enable it.

    In the Devices tab, click on the drive, Edit and enable SMART monitoring.
    In the Scheduled Tests tab, click on the drive, Edit, and set up a short self test. Enable it and set Hour "2" on Sunday or something like that. Save it. Then click on your enabled test and the run button. It will take 5 minutes or so to complete a short drive self test.

    To see the results, go back to the Devices tab, click on the drive, then on the Information button.

    A dialog window will pop up. Click on Attributes tab. (Extended information should be reviewed as well.)
    If we're talking about a spinning drive and the following attributes are incrementing up, they're indicative of a future drive failure.


    SMART 5 – Reallocated_Sector_Count.

    SMART 187 – Reported_Uncorrectable_Errors.

    SMART 188 – Command_Timeout.

    SMART 197 – Current_Pending_Sector_Count.

    SMART 198 – Offline_Uncorrectable.


    **One or two, in the raw count, means nothing other than keep an eye on it. However, if these counts are incrementing upward, a drive failure may be in the making.**

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!