nginx, phpMyAdmin, mysql - can't access pages in shared folder

  • Hi all


    Raspberry Pi 3 Model B Plus Rev 1.3

    OMV 4.1.35.1

    Arm v7


    Needing to setup a simple web site at home to run some php code.


    Followed this video :


    only saw at the end it was OMV3, but it appears to work with OMV4 - sort of :)


    Have updated the system, installed Plugins for mySQL and Nginx.

    Created a shared folder 'www'

    under ACL, permissions set to RW for Dave ( that's me ), adm, www-data and another www-data


    General Settings Port for OMV was changed to '90' so as to not conflict with the nginx port 80.


    Services > SMB - enabled for the www shared folder, and I can map to the folder from my win PC.


    Services > mySQL enabled and I can browse to mySQL and login to mySQL.


    Services > Nginx - Enabled and PHP ticked. URL shows as 192.168.1.135:80


    Click on the URL and get a new browser tab with "Welcome to nginx" message.


    phpMyAdmin - I can browse to http://192.168.1.135/phpmyadmin/ and get the login for phpMyAdmin, and can log in.


    BUT - when I try and go to http://192.168.1.135/index.html all I get is the 'Welcome to Ginx" page. Not the index.html page that's in the shared www folder


    IF - I go to Services > Nginx > Servers > Edit, and turn ON "Use root", Save & Apply, then I can see the correct page at http://192.168.1.135/index.html BUT then the phpMyAdmin page shows error 404 Not Found.


    What am I missing ?

  • Putty terminal for php -v :


    root@OMVpi1:/# php -v

    PHP 7.0.33-0+deb9u9 (cli) (built: Aug 24 2020 11:14:22) ( NTS )

    Copyright (c) 1997-2017 The PHP Group

    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies

    with Zend OPcache v7.0.33-0+deb9u9, Copyright (c) 1999-2017, by Zend Technologies

    root@OMVpi1:/#

  • ok. I think this is working now


    messing around with some google searches, and came across this :


    First, remove the symlink you just created by running:


    Code
    rm -rf /usr/share/nginx/www


    That won’t delete phpMyAdmin, it’ll just delete the symlink. Now we’ll create a new one using:


    Code
    sudo ln -s /usr/share/phpmyadmin/ /var/www/html/phpmyadmin


    which I edited to :

    Code
    sudo ln -s /usr/share/phpmyadmin/ /sharedfolders/www/phpmyadmin


    I can now browse to the myPhpAdmin page


    Hope this helps someone else in the future

  • DaveOB

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!