Portainer Alternative

  • And I managed to snatch the beginning of Yacht logs, clearly stating it's using some user with UID and GID of value 911. Can this be the cause

    No this is the same on the install I have just done, from omv-extras, I deleted previous post when I went over what I had posted, this is log output from my install.


    Raid is not a backup! Would you go skydiving without a parachute?

  • Huge thanks again geaves! Funnily enough my logs look the same as yours until the "Permission denied" line...


    Another thing which came to my mind is that I installed OMV on top of minimal Debian installation following https://openmediavault.readthe…stallation/on_debian.html, not from the original ISO, as I wanted to set it up on BTRFS. So maybe it has some extra firewall/security settings... I have the same setup on VBox, so not surprisingly I'm hit by the same error there. I could try setting up a VM using original OMV ISO, but that wouldn't prove much more that I've already learnt from you.


    For example, apparently I have AppArmor running:

  • I'm going to have reinitialise my VBox again and test the zfs option having seen what you have done to see if can replicate it, I'm wondering if the storage drive gets deployed when one changes the docker install to zfs.

    Raid is not a backup! Would you go skydiving without a parachute?

  • OK redeployed my vm using the ISO I have installed yacht without installing Portainer

    As you can see I have installed docker on zfs, created object filesystem -> data as confirmed above, then created a shared folder -> Access Rights Management -> Shared Folders -> docker, so the absolute path is /dozer/data/docker.


    OMV-Extras -> Docker changed the path to point to /dozer/data/docker -> Save


    Installed docker via OMV-Extras, output from docker info above


    OMV-Extras -> installed yacht from here, output from docker logs yacht:

    as you can see this has installed as expected without errors.

    For example, apparently I have AppArmor running:

    Output from my VM as per your observation;

    Code
    apparmor_status
    -bash: apparmor_status: command not found

    Raid is not a backup! Would you go skydiving without a parachute?

    Edited once, last by geaves ().

  • apparmor should not be installed on Debian by default. I would remove it.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thanks again geaves and ryecoaaron for helping me to debug it! It was indeed AppArmor problem. I disabled it in the way described at https://wiki.debian.org/AppArmor/HowToUse#Disable_AppArmor and surely Yacht page opens nicely on port 8001. I hope this thread helps anyone facing similar issues in the future.


    I honestly don't know how AppArmor got there in the first place, I tried to install Debian as lean as possible. On the other hand that Debian wiki discourages from disabling it, but I bet in my scenario (OMV-based NAS in internal network, with a few extra docker containers) I should not be worried too much.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!