OMV installation upon raspios (R-pi 4) crashes every time

  • Hi folks,

    I tried to install OMV 5 upon my raspberry 4 a couple of times but it crashes all the time.

    I prepared an micro sd card with this os: 2020-08-20-raspios-buster-armhf-lite

    This works fine so I prepare ssh, do "apt-get update" and "apt-get upgrade -y" and changed the password.

    Then I run the OMV installation script from the manual:

    wget -O -…Script/raw/master/install | sudo bash

    This runs for a while, then interrupts, delivering the error in the screenshot attached.

    I have troulbes understanding the warning: I do this by ssh (have to since it's a buster) so I don't know how to do this other than via ssh. The raspi is attached to ethernet by cable because this was recommended.

    I really don't know what's wrong, so could anyone please help me out?

  • The fastest easiest way I found for the pi4 is install pios buster.

    Then do the standard raspi-config setup and enable ssh.

    I highly suggest setting a static IP to the pi from your dhcp server and not in the pi.

    Once your pi is configured run the install script command for omv5. It will detect your pi4 and install. It will disconnect like you saw when it adds the network adaptor to omv. Simply reconnect your ssh session and verify the ip with ifconfig.

    Then browse to the omv gui.

    It really is a simple process on the pi4.

  • Thanks mate - that's what I did. If you check the 1st screenshot you can see that the installation crashes during something like "dhcpcd5" which seems to be manipulated on the raspberry os but fails.

    Last ssh line in log is "client_loop: send disconnect: broken pipe"

    It's as if the script tries to change something in some network configuration and by doing this robs itself of the needed connection...?

    And what the heck is a broken pipe??

  • Okay, the last one was a typo and my bad.

    But more importantly, it seems to have been the point to actually use putty instead of a linux shell terminal.

    It works, thank you very much for your time and patience!!! :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!