OMV5 - BTRFS formatted HDD mounted at "/media/pi" instead of "/srv/dev-disk-by-label-label"; "File systems" tab (web gui) "loading" indefinitely

  • After an energy shortage (coincidence, I now think), the disks on my Raspberry Pi 4 started to be mounted at a different location (“/media/pi/label” instead of “/srv/dev-disk-by-label-label”). I tried to reboot, but the error persisted.

    Checking OMV5 web gui, I noticed that the "filesystems" tab was not working (kept "loading" indefinitely). Besides that, the system was giving me many "RPC something" errors that I couldn't understand.

    So, I did a fresh install of everything, but, as I reconnected the HDDs, they kept being mounted at “/media/pi/label” and the OMV gui was acting the same way (the “filesystems” tab still wouldn't "load").

    I, than, disconnected the two HDDs (they're connected via USB 3, and the dock has its own power source) and the web gui became responsive again, showing the “filesystems” tab. After that, I connected another two HDDs, and everything worked.

    The only difference between the HDDs sets is that the problematic ones are formatted with BTRFS (the other two, that are working, are NTFS).

    I've already verified the data on the BTRFS HDDs, and everything seems fine (I can access it as the disks are mounted on “/media/pi/label”; using SSH for that).

    I tried to include the disks manually on “config.xml” (and ran "omv-salt deploy run fstab"), but didn't work (I copied the UUID and set the mount point at “/srv/dev-disk-by-label-label”, as it was before the problem started).

    I really don't know what changed on the system, because it was working flawlessly (the USB 3 dock I use had a problem with some sort of linux driver regarding UASP, but I solved it black listing its load at boot - including the "usb-storage.quirks=aaaa:bbbb:u" at "/boot/cmdline.txt"). Besides, as I mentioned, I can access the data no problem; it's OMV5 that seems to not to.

    What am I doing wrong? Is it not possible to reconnect a BTRFS formatted HDD on another installation?

  • Using btrfs on an USB drive could cause issues.

    Have you checked dmesg for warnings regarding write barriers as mentioned in the btrfs Wiki?

    Is it not possible to reconnect a BTRFS formatted HDD on another installation?

    Why should it not be possible? Just use a Linux laptop or a live distro and you should be able to mount and access the drive (if btrfs-tools is installed)

  • I can access the data, no problem. Is OMV that doesn't mount the drives or see the file systems on it. As I mentioned, logging using SSH I can manually mount the drives and access all the data, no problem. But OMV doesn't recognize the file systems (on the corresponding tab - web gui - I can see nothing, because it stays "loading"). OMV sees however the disks.

    See the images attached.

  • Yes, already tried. Did many fresh installs, and, as soon as I connect the disks, the problem occurs: the file systems tab becomes unavailable (keeps "loading"), although the disks appears on the disks tabs - and I can manually mount them and access the data (SSH). I read on others threads that some RPC errors can be corrected by clearing the browser cache, so I did it many times (even used different browsers and machines). But I think the problem is located at the server side, as the drives are not automatically mounted.

    I searched for errors regarding BTRFS on the forums, and was wondering if I need to install something that the installation script did not include. BTRFS-progs is installed though.

  • I cleared the Syslog and tried to access the file systems tab again.

    Caught this:

    Oct 3 07:21:14 raspberrypi rsyslogd: [origin software="rsyslogd" swVersion="8.1901.0" x-pid="677" x-info=""] rsyslogd was HUPed

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: PHP Fatal error: Uncaught TypeError: Argument 2 passed to array_keys_exists() must be of the type array, null given, called in /usr/share/php/openmediavault/system/filesystem/backend/ on line 286 and defined in /usr/share/php/openmediavault/

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: Stack trace:

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #0 /usr/share/php/openmediavault/system/filesystem/backend/ array_keys_exists(Array, NULL)

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #1 /usr/share/php/openmediavault/system/filesystem/ OMV\System\Filesystem\Backend\Manager->enumerate()

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #2 /usr/share/openmediavault/engined/rpc/ OMV\System\Filesystem\Filesystem::getFilesystems()

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #3 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->enumerateFilesystems(NULL, Array)

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #4 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #5 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethod('enumerateFilesy...', NULL, Array)

    Oct 3 07:21:26 raspberrypi omv-engined[1889]: #6 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getList(Arra in /usr/share/php/openmediavault/ on line 142

  • I found that thread too. But my drives are BTRFS formatted, not ZFS. Still, I installed the ZFS plugin (actually, I've installed everything trying to solve the problem), but didn't change anything.

    I'm starting to think that it will be easier to wipe the drives and start over... this time, no BTRFS.

  • Yes, I've installed and uninstalled every plugin on the list (and, to ensure nothing I did was causing the problem, I've formatted and did many fresh installs of OMV on the system disk).

    I'm really thinking of giving up on this. There must be some configuration I need to do for OMV to automatically see the BTRFS file system, but figuring it out is taking too long (two weeks of installing and reinstalling).

    I really appreciate your help, though. It's the first time I post something on forums to try to obtain solutions, and you've been quite responsive. Thanks a lot.

  • There must be some configuration I need to do for OMV to automatically see the BTRFS file system

    So far did not have any issues (using BTRFS on two OMV boxes and my laptop). Worked out of the box.

    Maybe it is an issue with your USB enclosure in combination with BTRFS as mentioned above.

    Sorry, you did not find a solution for your problems. As you say, might be the best option to start from scratch.

    Good luck:thumbup:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!