Platform regulatory error in my ACEPC T11 plus

  • Hi guys;

    After installing a clean OpenMediaVault 5.5.11 and upgrade all packages I found some errors.

    This is the first one:

    dmesg --level=err
    [ 7.899433] platform regulatory.0: firmware: failed to load regulatory.db (-2)

    I found this link, with interesting information:…-regulatory-db-(-2)-Error

    Seems that wireless-regdb package lacks two files: regulatory.db & regulatory.db.p7s

    I fixed the missing files with this lines of code:

    sudo su
    cd /lib/firmware

    The wireless-regdb package is not installed in my system.

    When i try: apt-get install wireless-regdb

    I get:

    Why is going to remove linux-image-5.7.0-0.bpo.2-amd64 linux-image-amd64 ?

  • Hi guys;

    I'm not using wifi / bluetooth / audio. Just I'm curious about how to fix it.

    I think removing linux-image-5.7.0-0.bpo.2-amd64 linux-image-amd64 will render my system unbooteable. I'm correct?

    root@openmediavault:~# uname -r
  • Hello, I have the same hardware than you.
    See here for my review (Mini PC low power OMV NAS : ACEPC T11).

    I also get the same error message, plus others.
    You have to know that the wifi card of that PC is really shitty. (same for Bios, Bluetooth and probably others)
    As an example it is impossible to install wifi drivers for it with Windows 10 v20.04, you have to choose between :
    - using an up to date Windows without wifi


    -using the manufacturer Windows version, not up to date, but with wifi.

    In total there are 9 lines of errors at boot with the standard install :
    - plateform ....

    - firware_class ....

    - intel_sst ....

    - brcmfmac ....

    - brcmfmac ....

    - Bluetooth ....

    - Bluetooth ....

    - Bluetooth ....

    - brcmfmac ....
    I was only able to remove lines 6 to 8 by selecting the 2nd bluetooth option in the Bios.

  • Hi stephane;

    Same problem here;

    I fixed the platform regulatory.0: firmware: failed to load regulatory.db (-2)


    cd /lib/firmware
    sudo wget
    sudo wget

    I fixed a lot of Bluetooth missing files with:

    cd  /lib/firmware/brcm/
    sudo wget
    sudo mv nvram.txt brcmfmac43455-sdio.txt
    ln -s brcmfmac43455-sdio.txt "brcmfmac43455-sdio.\$(DEFAULT_STRING)-\$(DEFAULT_STRING).txt"
    sudo wget
    sudo wget
    sudo wget

    But still errors with SST intel audio, and some errors with bluetooh

    Maybe the best approach is simply to blacklist audio/wifi&bluetooh

    Also I noticed some problems rebooting;

  • Also I noticed some problems rebooting;

    Do you mean random reboots? I solved that with the "nomodeset" option.
    or that you have to reboot regularly ?

    On my side, 3 months ago I never managed to make wifi works with Windows 20.H2 or Ubuntu 20.10 .
    Now I am still using the ACEPC T11 with OMV v5 and ethernet cable.
    I have remarked that the ethernet link is not very stable, there are micro connection losses and lost packets, that's probably the full network controller which is shitty.

    In addition of that, I have to reboot regularly (sometimes after 1 week, sometimes after 1 month) otherwise the SMB shares are broken (files suddenly becoming read only or folders becoming empty). That could be a software OMV bug or a hardware problem, that's impossible to debug.

    I definitely don't recommend that ACEPC T11 for any use case.

  • Hey folks! Brand new to OpenMediaVault (and to Linux for that matter), but I wanted to report I had the same error on a fresh install of OpenMediaVault 5 onto my old Acer Extensa 5630 laptop.

    The fix proposed by the OP asch75 has made the error go away, and similarly when I looked in to apt-get install wireless-regdb, the output seemed to be tending towards overwriting the active kernel. I did not proceed!

    I'd love to understand better where the registry.db error comes from, what it might impact, and whether the OP fix is truly a fix, or just makes the error go away.

    Thanks to all for the work contributing to the OMV forums - I very much appreciate the vibrant resource as a new user.:)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!