Oscam und Portainer Problem mit Smargo

  • Hallo,


    Hab hier ein großes Problem, hab das OMV auf das neue Image OMV5 installiert, und unter portainer auch die Oscam am laufen, nur leider findet er mit diesen einstellungen nicht meinen Reader warum auch immer, ich bitte um Hilfe da er auch libusb error anzeigt bei mir.


    Siehe screens :-)

    Code
    hdplus [smartreader] Libusb init error : -99
    2020/10/04 12:58:51 2CBD78E9 r   (reader) hdplus [smartreader] Cannot open device: Serial:Reader CDAF630
    
    Serial:Reader CDAF630 serial reader ist das hier.

    Thermaltake V.2.1 & ASRock-J4125-ITX mit picoPSU-120 & Salcar 72W Netzteil und 2x 8GB Ram von Crucical & Seagate IronWolf 8TB & Transcend 32GB inkl WINTV Solo mit DVB-C



    :thumbsup::/

  • ich hatte ähnliche Probleme einen smargo reader zum laufen zu bekommen. Für mich war die Lösung das Reader Protokoll in oscam auf "smargo" umzustellen und sicherzustellen das die Rechte der dialout gruppe und des abc users im Container korrekt [Referenz] sind. Ich nehme an der linuxserver-oscam container ist im Einsatz dann können die Berechtigungen wie folgt angepasst werden [Referenz - "Custom Scripts"].


    Inhalt der Datei:

    Bash
    #!/bin/bash
    
    echo "**** setting permissions for Card Reader ****"
    groupmod -g 20 dialout
    usermod -a -G dialout abc

    Die Gruppen-ID ist gegebenenfalls an das eigene System anzupassen.

    omv 6.0.42-2 (Shaitan) | x86_64 | 5.18.16-1~bpo11+1 kernel

    Plugins: omvextrasorg 6.1.1 | kernel 6.3.3 | flashmemory 6.2

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!