Public IP address not connecting to Openmediavault server

  • No matter what I try, my public IP address (e.g. from is not connecting to my OMV server. I have tried connection by both entering the public IP address into my browser, and by using a DuckDNS url.

    Note: This issue first happened after my router was reset. Beforehand, it was connecting when I used the public IP address.

    I have already done the following:

    -Added port forwarding in my router to go my OMV server for ports 443 and 80. (Had it that way before router was reset).

    -Added my OMV server LAN IP address as a Static IP address in my router.

    -Updated /etc/resolv.conf file in my OMV server to have my new router IP address (before reset it was now it is

    -Re-added all SSH and SSL certificates.-Added SSL to "General Settings > Secure Connections"-Tried connecting with "Enable SSL/TLS" and "Force SSL/TLS" disabled or any combination of those two options.

    -Added to "Network > Interfaces > DNS Servers" (Note: In this menu the IPv4 connection method is set to "DHCP" and the IPv6 connection method is set to "Disabled").

    -Successfully pinged and and received responses.

    -Successfully ran "apt-get update" and "apt-get upgrade" (selecting no configuration changes for most options)

    -Restarted my OMV server several times.

    I am at a loss. It should be connecting simply by typing http://publicipaddress. Is it a configuration issue with OMV or my router? What else am I missing?

  • Many routers will not connect to the WAN IP address (or a hostname that resolves to the WAN IP) from within the LAN.

    The capability a router must have for this to work is called NAT Reflection, NAT Loopback, or Hairpin NAT. Check your router settings.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I found the solution.

    I was putting as my source/external address in the port forwarding menu. In my router this would not work. Instead that field simply had to be left blank.

    Now both my 1) url and 2) entering the Public IP address into the browser both work and allow a connection to my OMV server. This is resolved.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!