Rsynce Subfolder destination sync issue

  • Hello everyone…


    I do hope that someone may offer a suggestion to rectify a Rsync problem that I’m facing…


    Background:


    Equipment: Synology NAS


    Remote OpenMediaVault NAS


    Utilizing the Rsync GUI interface within OMV


    I have a fixed wireguard VPN connection between the 2 locations. Having no problems pinging the various devices in both directions.


    I have established a Rsync “Pull” connection from the OMV back to the Synology.


    I want to pull a specific sub-folder from the Synology, so let’s say the path would be “Volume1\Music”.


    On the OMV I have a large share established called for arguments sake “Data”.


    On the OMV I want to create a subfolder called “Music” to have as the destination for incoming files from the Synology.


    I’m able to pull the files with no problem, save for the fact that they are placed in the root of the Share and not withing the subfolder...


    Within the GUI interface the following is the destination information “Data [on Volume1, Data/]”. I’m missing the knowledge to be able to have the files dropped into the /Data/Music subfolder.


    I do have that subfolder created on the share. So the is located at "Volume1/Data/Music". I can't connect or place file in this Subdirectory


    Anyone with any suggestion on just how to configure this would be most appreciated


    Cheers

  • You need to create an additional shared folder that is pointing at /srv/dev-disk-by-label-xxxx/Data/Music

    and use this shared folder for the rsync job.

    So you need a nested shared folder.

    I thank you for the information...


    I then gather that for each sub-directory that I wand to backup, I must create a specific shard for that directory?. Am I reading that correctly?


    Again, thank you for your time....


    Cheers

  • Maybe there is a misunderstanding.


    If you have a folder with several other folders inside, you can just use rsync on the parent folder and enable the recursive switch (recurse into directories)


    Again thank you for your reply...


    That was precisely the problem... I did have a parent folder with sub-directories contained with in... The catch was I didn't want all the sub-directories to be contained in the synchronization...


    So, I had to find a solution that allowed just specific sub-directories to be synced... Once I clicked that I would have to run multiple rsync sessions to address each specific sub-directory the rest was easy...


    Got it now working well... Thank you for your assistance...


    Cheers

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!