issue getting rid of an unwanted mounting

  • i have some confusion on how to get rid of an unwanted mounting so i am seeking some advice...

    a bit more background:

    the issue came about because when i built the system (replaced omv steoneburner) i did not have the hard disk i am referring to attached to the system. i attached this new 1Tb hard disk to be the subversion repository file system in my omv5 system.

    I was manually remounting the file system as needed whilst i installed, configured & tested the svnserve service - i am using the svn protocol to access repositories using tortoiseSVN, and in process of trying to work out a reasonable way to setup the system, i tried using the Filesystem tool to mount the drive but for some reason the file system would not automount on restart (i probably missed a step somewhere as the Filesystem tab listing showed it as unreferenced) .

    inevitably i added the file system to the fstab and have it mounting ok on bootup but of course there is the remembered mounting via OMV that i am having difficulty getting rid of.

    full fstab is this:

    the second OMV section entry that begins with "/dev/disk/by-id/ata-WDC_WD10EZEX"

    # >>> [openmediavault]
    /dev/disk/by-label/DATA        /srv/dev-disk-by-label-DATA    ext4    .....
    /dev/disk/by-id/ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2        /srv/dev-disk-by-id-ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2  .......
    # <<< [openmediavault]

    is the one i want to get rid of because it duplicates the mounting further up the fstab:

    # Device /dev/sdb 931.51Gb svn data drive 
    UUID=99d41060-856b-4547-b6ac-cbf7431ed224 /srv/svn ext4 defaults 0 0

    and i end up with two copies of the same file system mounted in two separate folders under /srv

    root@openmediavault2:/srv# ls svn  aquota.user  config  lost+found  repos
    root@openmediavault2:/srv# ls dev-disk-by-id-ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2  aquota.user  config  lost+found  repos

    the file system mounted to the folder svn matches this item in fstab UUID=99d41060-856b-4547-b6ac-cbf7431ed224 /srv/svn

    the file system mounted to the folder "dev-disk-by-id-ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2" matches this item in fstab /dev/disk/by-id/ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2 /srv/dev-disk-by-id-ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2

    the omv5 documentation suggests that i can get rid of this second one by editing the config.xml database (partial copy below) but i cant find an entry that matches to second mounting (see below)

    any suggestions on where to look next ?

  • You should be deleting the mount from within Filesystems in the OMV GUI. Is there some reason you can't?

    Google is your friend and Bob's your uncle!

    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • Thanks for the reply, (and i added a bit more background to the original post above):

    because the documentation states that "The delete button actually deletes filesystems, using wipefs -a. This will flush filesystem, raid or partition-table signatures (magic strings). Be careful using this. "

    At this point in time I do not want to wipe the disk volume, hence i have not used the Delete button on the Filesystems page.

  • i did a bit more reading and found the "Filesystem Environmental Variables" page and the reference to running a salt process. there was a reference i saw that salt was the bridge between the config.xml and the fstab , therefore i ran the command "omv-salt deploy run fstab". Did not seem to do anything substantial, so i'll reboot and check again.:

  • actually, running the command "omv-salt deploy run fstab" fixed the fstab and mounting issue (no longer a duplicated mounting in the OMV section of FSTAB) so i deleted the "/srv/dev-disk-by-id-ata-WDC_WD10EZEX-00BN5A0_WD-WCC3F7SH5ZHP-part2" folder and the issue is all nicely cleaned up! file system is still listed in the Filesystems tab which is ok.

  • andykmv

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!