Cups Plugin for OMV 0.5

  • It is available in the omv-extras testing repo. Install the omv-exras plugin and enable the testing repo. It will show up in the plugins list then.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Is it stable enough to consider running...?


    The cups plugin is the only thing keeping me from upgrading my OMV 0.4 server to OMV 0.5... I have OMV 0.5 ready to go on another hard drive.. All I need to do is switch out the drives, but I need a stable working Cups plugin... If i had the money to replace my current printer with a network ready printer then I wouldn't care about the Cups Plugin...

  • The plugin just adds printers to cups. So, stability is fine. The 0.5 plugin even works with network printers.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The testing repo is for release candidates. We just haven't received enough feedback to move it to stable. I have it running on two systems without issues.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • They are in repos you don't have access to when they are unstable. I would say that when they are in testing it is a period when plugins still might be evolving, new features added or tweaks to existing.

  • Hi there,


    I read that and tried out myself the cups-plugin (0.5.1) , but it cant be enabled. Always get an error:
    "Communication error" and non of the settings (enable i.e.) is switched to on.


    Can anyone help?


    Thanks !!


    Wuffty

  • Works fine in my VM. Try uninstalling, reboot, and reinstalling. It should be enabled already when installed.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi ryecoaaron,



    thanks for this tip. I tried it already but only once. And I noticed now it was not correctly removed - using --purg this time helped :-)


    I had to do it twice but now it works. Though it was not enabled after installation...


    Thanks,


    Wuffty

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!