ZFS stopped working

  • Running the following;

    OMV 5.5.14-1

    ZFS Plugin 5.0.5

    Kernal 5.4.44-2.pve

    After latest OMV update - my ZFS pool cannot be seen by shares. I tried changing to various kernels ( and 5.4.44-1.pve) but still no luck.

    If I click on Shared Folders - all shares show n/a under Device. If I export and import Pool - it shows up under ZFS with status "ok", but if I try to create a new test share - the device dropdown is empty.

    If I try to edit existing share - I get the following error;

    Failed to execute XPath query '//system/fstab/mntent[uuid='47753d56-a12b-4c70-bd97-89bbf3aff968']'.

    Here are details:

    Error #0:

    OMV\Config\DatabaseException: Failed to execute XPath query '//system/fstab/mntent[uuid='47753d56-a12b-4c70-bd97-89bbf3aff968']'. in /usr/share/php/openmediavault/config/database.inc:78

    Stack trace:

    #0 /usr/share/openmediavault/engined/rpc/sharemgmt.inc(234): OMV\Config\Database->get('conf.system.fil...', '47753d56-a12b-4...')

    #1 [internal function]: Engined\Rpc\ShareMgmt->get(Array, Array)

    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)

    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('get', Array, Array)

    #4 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('ShareMgmt', 'get', Array, Array, 1)

    #5 {main}

    Any thoughts on what to try to get access to my share back?



Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!