eth0 keeps going back to 100mbps

  • It doesn't look like they install/upgrade anything.



    Still the same errors in the GUI on the plugins tab.

  • After the 3.2 backports kernel install I did a reboot of the server. It came up with eth0 at 100 again, so I switched it to 1000 and once again it switched itself back to 100 after a few seconds.


    I figured I should check that it's actually using the 3.2 kernel and it doesn't look like system is using the 3.2 kernel even though the install looked successful.


    Code
    root@openmediavault:~# uname -mrs
    Linux 2.6.32-5-amd64 x86_64
    root@openmediavault:~# cat /proc/version
    Linux version 2.6.32-5-amd64 (Debian 2.6.32-48squeeze3) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Fri May 10 08:43:19 UTC 2013
    root@openmediavault:~#
  • Try to install it manually via CLI:

    Code
    echo "deb http://backports.debian.org/debian-backports squeeze-backports main" >> /etc/apt/sources.list
    apt-get update
    apt-get install -t squeeze-backports linux-image-amd64 linux-headers-amd64


    After a reboot you should be at the backports kernel.

  • Actually I don´t think it is a hardware problem. But it would be interesting if a new mobo (same one) would fix the problem.
    Would try a new driver for those cards.


    Off: Got a similar error with my backports kernel... Only solution was to do it manually. And this is not the first time i read that the button did´nt install the kernel properly. Maybe the button needs to be redone from aaron...

  • Are you sure that your board has two 82573V interfaces? Lots of manufacturers put one 82573V and one 82573L on their boards.
    I doubt that the drivers are the culprit, Intel E1000E drivers have been included in almost any Linux distro since a long time. Have you ever been running this board with another OS, i.e. Windows? If it doesn't fall back to 100mbit when running Windows then the hardware should be ok.
    Do you run the latest bios firmware version? Sometimes it helps to bring it up to the latest version in such situations.

    Homebox: Bitfenix Prodigy Case, ASUS E45M1-I DELUXE ITX, 8GB RAM, 5x 4TB HGST Raid-5 Data, 1x 320GB 2,5" WD Bootdrive via eSATA from the backside
    Companybox 1: Standard Midi-Tower, Intel S3420 MoBo, Xeon 3450 CPU, 16GB RAM, 5x 2TB Seagate Data, 1x 80GB Samsung Bootdrive - testing for iSCSI to ESXi-Hosts
    Companybox 2: 19" Rackservercase 4HE, Intel S975XBX2 MoBo, C2D@2200MHz, 8GB RAM, HP P212 Raidcontroller, 4x 1TB WD Raid-0 Data, 80GB Samsung Bootdrive, Intel 1000Pro DualPort (Bonded in a VLAN) - Temp-NFS-storage for ESXi-Hosts

  • Yes, you are correct, this board has one of each. I had to install the e1000e drivers to get the NICs to work after initial installation.


    Code
    dpkg -i e1000e-2.6.32-5_2.3.2_amd64.deb


    The last OS on the machine was a variation of CentOS. Both NICs worked in gigabit mode. I have had a few others on there over the years and have never had an issue with the gigabit NICs.


    The board is a Super Micro PDSM4+
    http://www.supermicro.com/prod…/xeon3000/3010/pdsm4_.cfm

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!