Problem installing nextcloud/swag. Need DNS and/or config clarification

  • Hi,

    I am new to OMV and Docker. OMV 5 is running fine on my Odroid-HC2, but I can't succeed to make nextcloud work, even after looking TDL video and reading the "[How-To] Nextcloud with Letsencrypt using OMV and docker-compose" guide. I guess my issue is related to DNS registration and/or nextcloud config files.

    Here are the details :

    DNS :

    OMV5 and Nextcloud runs locally at home. As I have a blog at with my own domain, I can register new records, so this is what I did :

    - existing is used for my blog.

    - So I created a A record for "" pointing to my local IP address.

    - And I created a CNAME record "" pointing to "" A record.

    OMV5-Docker :

    I used stacks following TDL video "Easy Nextcloud Install in 6 Minutes with Stacks!".

    Regarding swag parameters, I used :


    - SUBDOMAINS=nextcloud

    I also redirected ports 444:443 and 81:80, but I have no issues with ports as far as I can see (router maps ports accordingly) and required ports are open internal and external (checked with nmap).

    Regarding nextcloud, I copy the nextcloudsubdomain.conf from the sample (no change), and have the following config.php, :

    ISSUE :

    Once the stack is deployed, swag logs looks fine so far. Certificates are created, and server is running.

    1) In my web browser, local address results in certificate error I accept, then image below is displayed.


    2) In my web browser, remote address "" results in time out !

    3) In my web browser, strangely remote address "" results in "Not Found. The requested URL was not found on this server.".

    - What is wrong here ? I am a bit lost.

    - If nothing obvious, how could I investigate the issue ? which logs and how to increase the level ?

    Thank you for your help,

  • votdev

    Approved the thread.
  • Relying to myself : issue was related to "NAT loopback" (or NAT hairpinning) : access to nextcloud web page was working outside of my LAN, but not inside. This is solved configuring your router (if possible) or setting you own DNS locally to resolve your DNS names locally. I had Pihole running on my LAN, and I use it for that purpose : just adding "" and "" to Local DNS records, poiting to internal 192.168.x.y IP address.

  • pled29

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!